Lumberyard on GitHub

Thanks to feedback from you, our community, we are happy to announce that Lumberyard source is now available on GitHub! Starting today you can get, manage, and submit code through the Lumberyard GitHub repo!

You can find out more information on our GitHub integration here:https://aws.amazon.com/blogs/gamedev/now-available-lumberyard-on-github

We’d love to hear your feedback.

Update Aug. 16 – Our repo is temporarily down as we address some customer feedback. Please check back soon.

Nice!

But the LY FAQ is mixed up:

Q. What are the license terms for Lumberyard?
No. When you publicly share an improvement to Lumberyard, you give other Lumberyard customers a license to use that improvement under the same terms that govern Lumberyard itself, and you give us a license to use that improvement without restriction.

The answer doesn’t match the question :slight_smile:

Yas!! This is awesome — super excited to see how this works for the Community :smiley:

Thanks for pointing that out. I’ll have our legal team take a look.

Is the repo still down?

Was anyone able to install Lumberyard through GitHub? When I execute get_bootstrap.exe it downloads files to “_temp” folder, but at the end cleans them and doesn’t start “Setup Assistant”.

Please make a proper submodule and/or subtree merge strategy to separate samples and gems from the main engine so they can be selectively downloaded/updated.

Hello, I wanted to know if there is any reward for promoting this engine, I work with some teammates developing a game, I have several contacts with developers who use unit and unreal, I am from Peru and I would like to be your evangelizer of that engine as there is in Unreal. : D. Well if you want xd

Hi @geotype & @Codsworth! Looks like we’re still working through a few kinks with the bootstrap executable. I was able to repro the checksum issue but this should be fixed now.

Could you try these five steps and let us know whether this issue is now resolved for you?

  • 1.Delete your existing fork by navigating to the “Settings” tab
    of their fork and clicking the “Delete this repository” button at the bottom of
    the page.
  • 2.Enter the name of the repo to confirm deletion.
  • 3.Go back to https://github.com/aws/Lumberyard
    and create a new fork.
  • 4.Clone the repo locally.
  • 5.Rerun bootstrap.exe.
    Thank you kindly for using our source on GitHub!

Forking repository is mandatory? I have just tried cloning repo from https://github.com/aws/Lumberyard.git and have same checksum error

I did not fork the repo - i did remove all previous attempts and did a fresh clone last night and it worked. Now i just have to figure out how to start blink-in thing - no windows icons or entries in the startup menu

Same problem. git_bootstrap.exe throws an error “Failed to finish acquiring needed files: The checksum of the downloaded file does not match the expected checksum…”. Workaround that by manually downloading and extracting binaries https://d3dn1rjl3s1m7l.cloudfront.net/1.10.0.0/lumberyard-1.10-448546c-pc_081817_114710-binaries.zip to the lumberyard root directory.

Hi @Codsworth & @rgjones! Forking the repo is mandatory if you wish to submit pull requests to the Lumberyard team. As it is, only admins of the repo have this ability which is why we recommend forking the repo so you yourself become an admin of your repo and have the ability to submit pull requests back to original repo you forked from.

@Codsworth, could you try the following steps and let us know if you still run into the checksum issue please?

  1. Remove the entire Lumberyard directory created by bootstrap.exe.
  2. Fork the repo (https://github.com/aws/Lumberyard).
  3. Create a local clone of your fork of the repo.
  4. Run bootstrap.exe.
    Thanks!

@Gamely, you’re full of great suggestions :slight_smile: Thanks for this feedback! I’ve logged a feature request on your behalf. Keep those ideas coming!

Thanks for this suggestion @rgjones! I’ve logged this request and will look into offering this option in a future version.

I have tried downloading this thing 5 or 6 times tonight - keeps failing - TG I have unlimited Internet

EDIT: I refreshed the repo - it’s working now - Thanks!

SetupAssistant.bat process does not create icons for starting Lumberyard Editor or Configure Project

Problem solved. Thanks!

I just tried to install via Github for the first time and see the same error. I forked and cloned just today. Here is the output:

Downloading files from url https://d3dn1rjl3s1m7l.cloudfront.net/1.10.0.0/lumberyard-1.10-448546c-pc_081817_114710-binaries.zip to E:\Lumberyard\Github\Beta-1.10\_temp\lumberyard-1.10-448546c-pc_081817_114710-binaries.zip
Downloading 2.14 GB @ 0.38 MB/s [=================|] 175% complete. ETA -1 day, 22:48:36.
Finished. Elapsed time 0:50:48.174440
Checking downloaded contents' checksum.
Failed to finish acquiring needed files: The checksum of the downloaded file does not match the expected checksum. Please try again or contact Lumberyard support if you continue to experience issues.
Cleaning up temp files

Looks like error appears only when cloning repo directly from https://github.com/aws/Lumberyard.git, not from personal fork. I wonder why :slight_smile:

Try to install 32-bit version of git. Initially i have installed git 2.14.1 64-bit and have checksum error even after cloning from my fork. So, delete 64-bit git, install 32-bit version of it and do the following steps just in case:

  1. Remove the entire Lumberyard directory
  2. Refork the repo (https://github.com/aws/Lumberyard).
  3. Create a local clone of your fork of the repo.
  4. Run bootstrap.exe.