LY not responding after Terrain Editor opening

Hi to all.

I have a problem with Terrain Editor: when i try to open it LY stops to respond so i need to restart LY.

I’ve tried to reinstall LY or wait for 2 hours but the issue remains.

I suppose that a problem is in retrieving heightmap data.

I noticed that the issue appears if i try to open Terrain Editor at created level. If i first open Terrain Editor and only then a level, it seems to be ok (but if i close TE and try to open it again the issue appears…)

No problems with other editors.

Hey @geotype, sorry for the issue — I’ve added this to our bugs list for someone to take a look at ASAP :slight_smile: Will keep you posted on the resolve status. Cheers!

Hi @geotype

Sorry for the issue, but I can’t reproduce the issue you had. Could you provide more detail of what is your steps?

  • Hardware spec, specially video card. ( run dxdiag and save out information )
  • Version of Lumberyard.
  • Step by step for your creation process.
  • The resolution, format of your terrain size and height map.
  • Screenshot of your level if possible.
    One more thing, do you have all folder writable permission?

Thanks.

Hi to all!

Below the answer to @Datouwan 's post:

1.4733-dxdiag.zip (13.8 KB)dxdiag.zip. Sorry, it is on Russian somewhere, i can translate if it is needed.

4698-ly-version.jpg

3-5. I create new level in default “Samles Project”.

4699-ly-01.jpg

4700-ly-02.jpg

push “Terrain Editor” button

and LY not responding

If i first open Terrain Editor and then a level, it is all work.

P.S. As i checked in Amazon Lumberyard folder all files seem to be writable. Any specific folder?

@geotype

Thank you for the reproduce steps. I still can’t reproduce the issue you had.

I saw that you had a integrated GTX 660 chip so I wonder if that is the issue of the video chip.

Could you switch the graphic performance to PC-low before you open editor? let me know how it goes .

I also found there are characters on the Terrain editor windows title, I was not sure if that was the root cause for the crashes. Did you find some other tools / windows has the same characters like I pointed blow, also crash editor ?

From your screenshot:

4774-window-title.jpg

My Terrain Editor Window

4775-window-title0.jpg

@Datouwan ,

  1. Low Graphics Performance didn’t solve the issue.

  2. The characters on the head of terrain editor are just “Terrain Editor (not responding)” :slight_smile:

May it be a conflict with previously installed and deleted Lumberyard 1.6?

I mean that i had LY 1.6. and Terrain Editor worked correctly there, after that i deleted it through Windows Control Panel and installed LY 1.9.

I will try to delete LY again and clean a register.

Thanks to all !

After reinstallation with register cleaning the issue disappeared (previously I did reinstallation w/o manual register cleaning (only use standart Windows Control Panel) and the error remained). So, possible it was any conflict with previously installed version.

If the error will appear I’ll try to track its cause.

@geotype

I am glad that you figured out by yourself on the end. I should ask you if there you tried to clean registry at first place. Sorry for the inconvinence.

Hey all,

So I’m having the EXACT same problem as Geotype and it’s 4 years later. Everything runs fine but then when I open the Terrain Editor it just becomes unresponsive. This has been happening for awhile. I recently upgrade to Lumberyard Editor 1.27.1.0 from 1.27.0.0 and that didn’t seem to fix the problem.

This problem started around the time I was adding my terrain to the map (which was quite large, max size if I recall). And after that it will no longer allow me access. I tried deleting the cache files and any assets I may have added with no fix. My fresh install of course didn’t fix it.

So I’m going to use CCleaner to unistall and clean out my registry. But my god, what would be causing an issue that requires me to clean out my registry with a fresh install? I really want to find a REAL fix for this as this fresh install is just a work around, not a fix in my opinion.

I wonder who else has this issue. It took me over a week to find this thread of someone who experienced my situation. All searches for my problem keep leading me back to the “Lumberyard Known Issues” page or “Lumberyard Debugging” page. Both of which hasn’t helped me in this situation. So can we get some people to look into this problem and possibly fix this at it’s root? I’m hoping it’s not an issue with having max size terrain.

The issue is resolved when you delete the following registry key “fancyWindowsLayouts”. Additionally we also discovered that you need to open/close Lumberyard’s Terrain Editor in docked mode. Being undocked will re-introduce these issues.

We request Amazon to please fix this bug. It has been around for a while and having this instability it causes bad end-user experience and confusion.

1 Like