Matchmaking stuckes on placing

I’m using ap-northeast-1. The matchmaking configuration I’m using is called
arn:aws:gamelift:ap-northeast-1:431120041160:gamesessionqueue/testGameLiftServer. The Queue I’m using is called arn:aws:gamelift:ap-northeast-1:431120041160:gamesessionqueue/testGameLiftServer.

After I tried to call start matchmaking, the matchmaking ticket stuckes on placing and then time out. I have tried to use start game session placement, the placement ticket stuckes on pending for a while and then time out. And I have checked the gamesessions in fleet, the game session is created and the arn is contains the ticket id. Am I missing something?

Sorry for my bad English.

Placing means that a match was made and now GameLift is trying to find a server process to accept the match and host a new game session

  1. Ensure your server receives the onStartGameSession callback and is calling AcceptGameSession
  2. Ensure your server is health: look at your fleet metrics to ensure your fleet has a available game sessions and healthy processes
  3. Pull your server logs for the game session, or use remote instance access to log into your fleet

When debugging game session creation issues, I would recommend scaling down to 1 process on 1 instance so you know exactly what machine is receiving the request. By looking at the logs you can quickly see what is happening.

I would recommend testing StartGameSessionPlacement calls with GameLiftLocal if you haven’t as this is what FlexMatch will be calling to create your game session.

Hope this helps

1 Like

thanks for reply

I have tested StartGameSessionPlacement. The onStartGameSession is called and Game Sessions is Actived. And all server process is healthy.

the game sessions named GameLiftTutorialMatchmakingConfigurationExample are created from StartMatchmaking and the game session without name are created from StartGameSessionPlacement. The game sessions are created by StartMatchmaking or StartGameSessionPlacement and all of them are healthy and I can join then by open the ip:port directly but the matchmaking is still stuck on placing status and gamesession placement is stuck on pending status. How to know why it stucks?

the game session is created and actived. But the game session placement will time out after few minutes.

Thanks for the extra information. The GameLift team is looking at your fleet/sessions and will hopefully have an update soon.

Thank you very much. I’ll test it with ap-northeast-2. I think it’s a bug(I’m not sure, so I’ll test it with ap-northeast-2).I’ll tell you if it works.

It works in ap-northeast-2. I’m pretty sure now there is a bug in ap-northeast-1 region

Hi @lion547016,

I’m glad to hear it works for you in ap-northeast-2. I apologize for the inconvenience this has caused you.
We just released a hot fix to ap-northeast-1 to address the issue. Feel free to test there again and let us know how it goes.
Again, my sincere apologies.