My feedback from LY 1.25.0

To avoid this problem it is enough to keep re-saving or converge models in the format of. fbx. Fbx is supported absolutely everywhere and it is the standard when creating games

@didzey I know , Thank you for your explanation :rose: :pray: :slightly_smiling_face: but this is not the solution you suggested, I talk about user-friendly & matching and passing Unity and Unreal and Cry, I hope you realize that one of main strategic goal is to support new users migrating to lumberyard :wink:

----- review 07 -----

----- review 07 -----

Next Issue : AI Behavior Tree 1.25 or 1.26 :wink:

----- review 08 -----

I made a video tutorial about make a function in Script canvas , we know some functions , can return a value like number, bool , entityId , etc or get input a value…

Is it possible “return value/get input value” in new feature function script canvas :question: :thinking: I can not find this issue , does not exist , am I wrong :question: :face_with_monocle:

----- review 09 -----

----- review 10 -----

We know Script Canvas is not support Global Variable , so I suggest to Script Canas Team , Please make a data component for number/bool/entityID, array , map , etc

01- “global variable” add button with exist index for variables
02-“global variable” delete button with exist index for variables

We can Get/Set by address the define in data component

I made a new video tutorial and simulate global variable by Point Light data :wink: in LY 1.25 :point_down:

Looks to me like the cosine function is working fine, it is just expecting inputs in radians. Cosine of 90 radians is -0.448.

1 Like

@JamesKythera NO , NO :exclamation:Here is the big problem and This is the problem , if you see this picture , you see value correct for all functions :expressionless: :neutral_face:

please see this table picture :point_down:

please read full this content :point_down:

Thank you for your feedback @JamesKythera :slightly_smiling_face: :rose: :pray:

@LS1 Great Job , Thank you for Data Component :heart_eyes: :star_struck:

I think the data component with variables can be hidden in Entity Inspector and only accessible with nodes in the Script Canvas (But data component to be shown Global/Static Variable panel inside Script Canvas), Of course I have a suggestion, if it is possible to add static variables as well, although I can simulate static variables like global variables, I think it is much better to add it officially to Script Canvas :slightly_smiling_face:

:point_up_2: :point_up_2: :point_up_2:

DOES WORK , I SOLVED for OUT Param/Result Number :heart_eyes: :star_struck:



------EDIT -----
at first looks, function concept in the Script Cannvas seems complex, but in any case, the REVIEW 08 IS SOLVED COMPETENTLY :sunglasses: :100:%

.
.
.

------EDIT 02 -----
:boom: :point_down:
REVIEW 04
REVIEW 07
REVIEW 08
IS SOLVED COMPETENTLY :white_check_mark: :100:%

:boom: REVIEW 03 IS SOLVED COMPETENTLY :white_check_mark: :100:%

We must use “Convert Degrees To Radians” Node , now values is correct :slightly_smiling_face: @JamesKythera

-------- EDIT --------
Now I can create objects that float in the sky, like the UFO spaceship :star_struck:

1 Like

Thank you @Yeshua :rose: :pray: I know NOW , default param is radian not degree :joy: someone do not told me , I discovered myself , I must use “Convert Degrees To Radians” Node :grin: :smile: I can create objects that float in the sky, like the UFO spaceship :heart_eyes:

Is there anyone to see and check Review 02 ? :blush: :point_down:

@_AhmadKarami The tooltip tells you that it is in radians.
image

2 Likes

@Yeshua Why you want continue this issue !?!!
I reported this issue with SOLVED FLAG all posts!

@_AhmadKarami I was only trying to help you and other people who see your post understand that they maybe be able to find information to better understand how to use a node by using the tooltips that appear over the inputs and outputs. I have found this to be particularly applicable with regards to the unit of measurement of a input or output value.

3 Likes

@Yeshua OK , Thank you :rose: :pray: :slightly_smiling_face:

Do you have a solution for ** Second review (Water ripple generator component) **?

I tried/tired a lot but result is nothing! why does not work “Water ripple generator component”?

Really strange! :thinking: :face_with_monocle: I gave its any component , it wanted but it didn’t seem to work!

you already test that component? Can you test that ?