Naming of Flipbook Animation Notifications Bus

I have noticed that the naming of EBuses that are used to notify components of an event that has occured usually have the name NotificationBus, like the following:

GameplayNotificationBus
InputChannelNotificationBus
UiButtonNotificationBus

However, the UiFlipbookAnimation, TagComponent, and ShapeComponent all have Notifications (note the additional “s”), like the following:

UiFlipbookAnimationNotificationsBus
TagComponentNotificationsBus
ShapeComponentNotificationsBus

Was this intentional? If so, what makes these different than the others? If not, should I make the necessary changes in source to prepare for the inevitable update/potential breaking of old code