'NetworkConnection.hpp': No such file or directory and More

1> Output:
1> WebSocketConnection.cpp
1>e:\Amazon\Lumberyard\1.24.0.0\dev\Gems\CloudGemWebCommunicator\Code\3rdParty\IoTDevice\network/OpenSSL/OpenSSLConnection.hpp(46): fatal error C1083: Cannot open include file: ‘NetworkConnection.hpp’: No such file or directory

1> Output:
1> OpenSSLConnection.cpp
1>e:\Amazon\Lumberyard\1.24.0.0\dev\Gems\CloudGemWebCommunicator\Code\3rdParty\IoTDevice\network\OpenSSL\OpenSSLConnection.cpp(24): fatal error C1083: Cannot open include file: ‘util/memory/stl/Vector.hpp’: No such file or directory

I’m sure you have build testing… still happens randomly. I only changed my Gem and it’s recompiling everything, something doesn’t make much sense here.

Either way… I’ll solve it adding full paths which is horrible but I cannot be stopped every time I hit build.

When I decided to re-run the configure command:

E:\Amazon\Lumberyard\1.24.0.0\dev>lmbr_aws.cmd configure
[WAF] Engine Root: E:\Amazon\Lumberyard\1.24.0.0\dev\

ERROR: The gems.json file at E:\Amazon\Lumberyard\1.24.0.0\dev\StarterGame does not contain an entry for the CloudGemFramework gem. You must enable this gem for your project.
ARGS: Namespace(cleanup=False, framework_directory=None, game_directory=None, root_directory=‘E:\Amazon\Lumberyard\1.24.0.0\dev’)

I just touch the cpps of my Gem and things are falling apart.

If helps someone, I added the Cloud Gem Framework

Executed lmbr_waf.bat configure and built everything again.
Now I have error C2039: ‘runtime_error’: is not a member of ‘std’ everywhere again -_-U

Sorry you are having problems building Lumberyard. Getting the team to take a look.

Can you clarify:

  • Which version of VS are you using? 2017/2019? (As it looks you’re using windows)
  • What build target are you running? debug, profile etc.

The warning about missing CloudGemFramework is expected with StarterGame as it doesn’t use CloudGems by default.

One thing you may want to do is check that CloudGemSamples project builds for you as this is the test project for CloudGems; it may help narrow down where the problem is.

Hope to have an update for you soon.

VS2019 and I tried profile and debug.

Since I applied the fixes proposed by me and other devs looks like I have no more problems regarding this!