New Version starting to show bad signs of this engine?!

The new lumberyard version 1.22.0.0 does not allow me to launch any new projects even after building them. It shows an error and I have reinstalled the engine 3 times, and rebuilt and made new games around four times each. Lumberyard should leave the second version up like 1.21.0.0 for people that don’t want to take all their time trying to work with the “better version” when I figured it out had no new updates for me and just made everything impossible to open, maybe a quick fix would be nice dev team.

1 Like

yeah i got error too even then I’m trying to create bare new project (ver 1.22).
I’ve take look logs files, engine wants something from Android SDK, it’s strange because i’m not interested in Android platform at all.
I’m even do not enabled option for android. but error still occrurs even if I’m want project just for win64 platform :))

but you can create new project manually from cmd console
1.open cmd promt from dev dir
2. cd bin64vc141
3. lmbr projects create TestProject2

C:\Amazon\Lumberyard\1.22.0.0\dev\Bin64vc141>lmbr projects create TestProject2
lyzard: Creating Project ‘TestProject2’
lyzard: Creating Project Folder
lyzard: Configuring Project

then you probably got this error

AwsNativeSDK:
==================================================================
AwsNativeSDK: Trace::Warning
 d:\ly\workspace\PKG_1_22\dev\Code\Tools\AWSNativeSDKInit\source\AWSLogSystemInterface.cpp(134): 'void __cdecl AWSNativeSDKInit::AWSLogSystemInterface::ForwardAwsApiLogMessage(enum Aws::Utils::Logging::LogLevel,const char *,const char *)'
AwsNativeSDK: [AWS] WinHttpSyncHttpClient - Failed setting TCP keep-alive interval with error code: 12018
AwsNativeSDK: ==================================================================

log file says - 1.22.0.0\dev\BinTemp\lmbr_create.log

[WAF] Engine Root: C:\Amazon\Lumberyard\1.22.0.0\dev\
[WAF] Executing 'build_win_x64_vs2017_profile' in 'c:\Amazon\Lumberyard\1.22.0.0\dev\BinTemp\win_x64_vs2017_profile'
[WARN] Missing JDK path from Setup Assistant detected. Target platforms that require java will be disabled. Please re-run Setup Assistant with "Compile For Android" enabled and run the configure command again.

after error press any key to countinue (wait till it 20-30min+ compile 2700+ files)

lyzard: Generating Visual Studio Solution
lyzard: Building Project
lyzard: Project ‘TestProject2’ successfully created.

finally you can run Project configurator and set as @defaut@ new project, then run editor.

1 Like

Thanks @fluffy at least you know alternatives to some mistake they most of had on their side. Hope it gets fixed soon or they put at least the version before hand back on the website to download. Anyway thanks a lot your a huge help! :grin:

I understand your frustration they actually should accelerate finalizing the engine and polish it for production it’s still on beta since 2016.

1 Like

Coudn’t agree more, to have to download tons of more addons and compile that never works, at least for me , and never help you its really odd.I think part of LY is they don’t have enough forum help to answer quesstions.
LY has a lot of very nice features like 32bit terrain, but to get access to very needed addons, like camera RIG, you have to compile. If it was easy nobody would complain.

UE4 does’t do this to you,hence why the ‘stable’ engine works, and you have access to 'beta
IF you want to try it, like unity etal.

You’d think the amazon name, money would showcase itself in an incredibly competitive engine but its just too hard to use. Doable yes , but my enjoyment factor is not COMPILING , before I can use engine features.

FIX those things, you’d have an incredible offering, and competiton breeds better options for all of us.

Thanks for everyone to help show that I do not just have a faulty version of lumberyard. As of now I am going to unity for my first big world project, but will be back to lumberyard in the future, since they are my favorite engine to work on as of now. I will still post and help people out as much as possible. :slightly_smiling_face:

Instead of creating half baked features they should have made this engine stable I’m testing the engine right now and ready to switch to CryEngine or Unreal if problems hindered development.

Just a notice to Amazon dev team, what on Earth are you doing? Can’t you see how all other engines don’t stay beta 3 years? All of them have launchers that organize engine installs, what if I made a game on 1.22 and 1.44 came out how to get 1.22 separate from 1.44?
this is another big flaw. Plus why the engine size is so big? when it’s downloaded CryEngine is only 3GB Lumberyard easily 20+ GB and when all dependacies are installed it reached 80+ GB, this is unbelievable.

Plus the Gems, and building of Gems it’s full of errors and problems, clashes everywhere and [preview] on tools and features that might be removed on next versions, you are on your own if you made a game with that [preview] feature so maintenance in future might be a headache.

I heard that Amazon game studios are cancelling games using lumberyard through the news because it hindered development, not my words read this https://www.google.com/amp/s/www.game-debate.com/amp/news/27276/newsAmpPage.html

1 Like

An official Lumberyard roadmap would help a lot.

I am not really sure why both Crytek and Amazon forked off CryEngine 3.8/4 and both started years long refactoring work which is still ongoing and resulted in both CryEngine 5 and Lumberyard 1.x beta being still in beta state and having less features or regressions to what used to be there.
CryEngine 3/4 was feature complete, stable, and at least two Triple-A games (Crysis 3 and Kingdom Come Deliverance) are show-cases what’s possible with the engine.
Sure, the GameSDK is ugly, the CryPhysics is outdated, the nodes-system unflexble, etc. but it was a full stable engine. In retrospective, it would have been wiser to maintain the stable engine as Lumberyard 1, while forking and doing the refactoring and create a Lumberyard 2 over the next years behind the scenes. That’s how UnrealEngine4 and SourceEngine2 were created.

Anyway, I also want to mention that I really like ‘Grand Tour Game’ game, I play it on PS4, it’s a great game and the graphics is certainly awesome. A bit unfortunate, it uses the very good rfactor2 vehicle physics engine, that won’t make into to the free Lumberyard download.

Some are a bit too spoiled, I would say almost no one cares how big the Lumberyard download is, be it 20GB or 100GB, it doesn’t matter these days at all. A triple-A engine isn’t a childs toy thing.

What matters is that Lumberyard needs certainly more developer resources, to catch up with Unity and Unreal. And it’s not that Amazon hasn’t the financial resources to fix that. I hope that Lumberyard has a great future, and gets the management support it needs and clear direction to get useful and kick ass as game engine in 2020/2021.

The status of Lumberyard is almost there, it needs like 12 months to get to a stable release. What’s needed is full PhysX integration incl cloths softbody and vehicle physics with samples. And a real commitment to Lua as the first party scripting language with full interfaces to C++, or drop Lua and provide a replacement.

1 Like

Yes @araccen I sure wish it becomes better or bezos wasted 80 million $ for nothing.

Here at our studio we are still testing it chances we might stick with it but other options are tempting.

I don’t see gems so bad, because it helps you enable and disable options that you don’t need in your game and I understand what “tedious to build a complete project for a gem” means, however, I think it was something temporary and physical, rivers and roads and many features that should be by default will be with the inclusion of Bundle Game Assets (1.22), although what I find necessary for the engine is:
-Only a language please SC and lua or C ++ (cof cof, more developers use C ++, please C ++).
(Unity understood this when it had boo, javascript, C # and now it only supports C # but it is BETTER).

-Focus on one thing at a time, lumberyard team should create a stable version with the tools in PREVIEW that are many and eliminating everything related to CryEngine before continuing to add more and more new tools, they are good, but if the engine were stable with the tools it contains now would be the best in the market (Unity just added holes to the ground).

-More ORGANIZATION is urgent that the engine has a launcher I can live with having three shortcuts on the desktop but not being able to access previous versions, close the editor to open the project configurator and what bothers us if they look a little in the forums don’t have a first person template

-Make better the documentation of the engine in general but above all I will highlight the scripting, they focus too much on canvas script I understand why they do it but it seems that they want the developers to only use SC.

-Sponsoring developers who know the community of other engines / youtubers (I don’t want to say that they buy them, but it would be nice if they invited them to use the engine, they could even get more feedback, maybe upload some tutorials to campaign with them etc, because what’s the point of having the best engine if there is no community).

Ok, that’s all watching the full text I think I wrote a lot and I hope not to bore you :sonriendo:

1 Like

Thanks for providing the workaround @fluffy!
@WashedUpStudios, sorry about the difficulty migrating to 1.22 and thanks for the post; I ran over the setup below and did notice bugs that I’ll be reporting internally. I’m curious to hear more details about the steps that failed for you so that hopefully the team here can fix them. Did you see an error “Mismatch detected between Launcher compiler defines and bootstrap values”?

The steps below should help work around errors when creating a new Project in 1.22…

1) Setup using SetupAssistant
a) Open \Amazon\Lumberyard\1.22.0.0\dev\Tools\LmbrSetup\Win\SetupAssistant.exe
Select “Customize”
b) On the Get Started page select the following options…
image
c) On the “Install required SDKs” page select “Install All”
image
d) I also needed to install the AutoDesk FBX SDK via the “Install SDK” button
Afterward all required SDKs were all installed…
image
2. Create New Project via ProjectConfigurator.exe
a) On the last page “Summary” of SetupAssistant select the option “Configure Project” to open ProjectConfigurator.exe (or open Bin64vc141/ProjectConfigurator.exe)
b) Select “Create New” > Empty Project (this step takes a quite while even with an SSD)
image
c) After this built, my default project was still set to StarterGame, so I had to change it by selecting my new project in Project Configurator and pressing “Set as default”. This definitely feels like a bug to me, so I’ll be reporting it. After making it the default project a checkbox will appear…
image
d) Because the default project wasn’t set while it was being compiled, we must compile again, otherwise we can an error like this when opening the launcher executable T.T
image
3. Rebuilding With Proper Default Project Enabled
a) Open a commandline in the dev/ root and run…
i) lmbr_waf configure
ii) lmbr_waf.bat build_win_x64_vs2017_profile -p all

After setting default project and rebuilding I was able to launch Bin64vc141/Editor.exe and the game launcher. Of course you can always use the commandline from the start as @fluffy suggested.
I’ll be reporting the bug I mentioned above, but definitely feel free to include repro steps for your particular situation, it will help us track it down locally. :slight_smile:

EDIT: I mistakenly rebuilt the wrong project when testing this (I have lots of versions on my PC). After creating the new project, all that is required is changing the default project to the new project, after which running the new project launcher and editor works as expected.

2 Likes

Hi @Gene I did not get the Mismatch between Launcher compiler defines and bootstrap values. I got a different error which after building my project on Version 1.22 trying to open the project, new gems built or right after building a brand new project it shows that the lumberyard editor has encountered errors and asks if I want to save my file or leave without saving. Never letting me into the actual editor itself just the lumberyard screen with asset processor working.

1 Like

Interesting, I haven’t been able to reproduce that error in Editor.
Would you be able to provide the editor log file after the crash occurs?
dev\Cache<your_game>\pc\user\log\Editor.log

Ok @Gene I just loaded into my new project I created about a week ago, that would give the error and want me to save a backup. But this time it let me in fine and I am not getting the error anymore. I also looked into the editor log files, but the only log files I have are for the starter game and that was the only one I could even get to the editor before I tried again today. So for now it seems the issue just fixed itself if anyone else wants to join in and give the editor log files when they get that error please do.

@Gene
Yes few if any care about the download wize but what MANY care about is the HUGE amount of ssd/hdd space the crazy setup takes. yes, UE4 isnt far behind, but at least with that initial committment with epic, you can do nearly anything OUTof the box, with LY not even close, andif you say want a camera rig, you need to compile the whole game instead of like UE4 you just add a plugin, and you’re done.

The issues have been there for MONTHS, so Im not so sure they’ll just get up and running, BUT given who owns AZ is, they SHOULD have no problem, time will tell.

I HOPE so,as I have a project with a terrain that would be hard to transfer to another engine ,etal.

I tried HARD to compile game which is NO biggie when thing just WORK, but I had errors, posted on forums and never got replies, proven by my posts, and given I have a huge project over at UE4, I had no committment here to fix it on my own,though I wish I could have given my LY project is very cool.

Can I get help with the compille game issues that I was forced into by LY engine, bc ‘camera rig’, doesnt, oddly come WITH the engine,why not ? The out of box 3rdperson char. witih is very cool, has TErRIBLE camera moveent/rotation, so I had no choice but to compile game.

Can I get help with that now ?
Love to get going!!

Does the Lumberyard installation size really matter that much? I mean it’s just a bit more than 20 GB in the year 2020. A 2 TB 3.5" internal hdd costs like 50 USD on Amazon.com. De-install a PC game (~ 60GB) :wink: (The resulting game package can be a lot smaller than 20GB, if you meant that.)

Lumberyard is so much more than what Unity offers out of the box, and even compared to Unreal4 the Lumberyard game engine is ahead of it’s time and comparable with triple-A game engines from EA and Ubisoft (that are not available for third parties). Unity has still a long road to catch up in several departments (renderer, refactoring). And Unreal4 hasn’t been seen in triple-A games recently. Look at The Outer Worlds, Shenmue III or Crackdown 3, they look and play really dated and B-grade in many ways (not bad games, but it limited by the game engine, and dev budget). Even Fallout New Vegas has a better physics integration than The Outer Worlds from the same devs but different engine. :rofl:

The problem is, all triple-A games nowadays use state-of-the-art very advanced inhouse game engines: e.g. Grand Theft Auto V, Assassin’s Creed Odyssey, Star Wars Jedi Fallen Order, etc. There is no way to compete with those big companies :sob: (EA, Ubisoft, SE, Activision, …), the only exception is Lumberyard :heart_eyes: which offers still very comparable features and graphics render quality. For recent Lumberyard games check out Kingdom Come Deliverance, Star Citizen, Grand Tour Game.

Lumberyard has features that even Unreal4 hasn’t on it’s list and may never implement: dynamic lighting (dynamic global illumination), real-time dynamic water, volumetric fog, open world map, real-time sandbox editor, etc. - you don’t get that out of the box in Unreal nor Unity. What Lumbaryard currently lacks is a big community, a marketplace / asset store, and more resources to finish the refactoring process sooner than later. Let’s cross the fingers.

4 Likes

Yes,we arent all rich,so it matters. UE4 size ( unity is fairly small for many reasons) is similar to LY,but for me anyway, and its not even close, ue4 IS my goto engine. I have a project here, but avoid atm (amazon may be doing that from what I read today) that can’t go forward bc, unlike ue4, LY has NO usable, stable 3rd person char ,out of the box. Without one, its impossible to do level testing.

Supposedly, a ‘camera rig’ would fix those things but that requires acc to user here, 80gb for all 3rd parties, and tho Iasked on forum, that I’m aware anyway,no one has yet replied to my shout for help not being able to get them compiled.No compile, game testing not happening, so no point.

ATM, I only have, bc I’m relatively POOR, a256 ssd for which many aps, 3d most, that I need to making UE4 work take up most of the room .

For much better performance I wanted to use the ssd but can’t so its my much slower5400 green WD.

Even if I find room which is not at all likely till I upgrade/buy another ssd,then I’m still stuck until I find out why I can’t get compilation working.

I downloaded 1.22 so I’ll try that later and hope whatever wasn’t working they fixed or was on my end, but given I asked for help on errors,got replies but still didn’t work, I doubt it,and given they allegedly laid many off, HM,further doubtful.

Anyway, I have a great project, I can’t work ON, till I get at least camer rig that mandates compilation working ,as compiling game is mandatory.