No gravity in editor game mode

Hi,

I’ve made an entity, attached mesh, sphere shape, mesh collider and rigid body physics components, unticked at rest initially in the rigid body physics component yet when I press ctrl+G to go into game mode, the console says I enter game mode, but the rigid body doesn’t fall down to the ground (set it in mid-air so that it would fall), as if there is no gravity or physics isn’t enabled when in game mode! Why is this, and how can I fix this?

@Techtime For some reason, the mesh collider doesn’t appear to work with the primitives from the Primitives Gem, try using the mesh primitives from /Engine/Objects/default/

Hi @Techtime!

Following your components list I was able to get the sphere to spawn, drop to the ground and be manipulated by the player controller from StarterGame.

Make sure that the Enabled Initially checkbox is checked in the Rigid Body Physics Component and that the Density/Mass of the component is set to around 10 or so. With a Density/Mass of Zero the mesh will not react to the physics engine.

Let me know if that works, if not send me some screenshots of your component settings and I will see if i can find out whats up.

Thanks!

So, @Amonster_LMBR. Using a primitive collider works, but using a mesh collider does not. Is this a known bug?

Also, I used the primitive_sphere.cgf from Engine/Objects/default as @kgwgk suggested