No ocean showing up, even with gem enabled and built

I went through the project configurator and adjusted the gems, I followed the steps and built the project, (I am using Visual Studio 2017), it went successfully, but now I can’t open the editor, I found that enabling Windows 8 comparability mode on Windows 10 worked and it opened, but when it does open, all of my levels have no ocean what so ever. Can someone help me, I don’t want to have to build my project again because it takes nearly 2 hours! this is kind of annoying now. (I’m trying really hard not to get annoyed at the engine and give it a chance, but it’s getting a bit hard to defend, I know it’s probably I didn’t build it correctly, or didn’t press a button or tick a box, but I’m just saying)

Also, I get this annoying “Bus is already connected” message show up every time the editor opens.

I am using VS 2015, and ocean was working perfectly until I enabled Water Gem to test the river tool. After adding the gem and compiling the ocean disappeared from my level and moreover, the ocean-related options are missing from the Terrain Editor:

6985-no-ocean-options.png

There are no warnings/errors related to any Gem in the console during project loading.

OK? So what does that mean then? How can I fix it, that was my question, am I supposed to rebuild it again? Remove the gem? What?

When you add the water gem the default ocean is removed, you need to add a new entity with an Infinite Ocean component.

Never mind I read the response quickly without thinking, I’m sure I can figure it out and I’ll give it a go.

Thank you, that was it, I wish I saw that sooner, it is kind of annoying, but a little bit better to have more control over the ocean. Do you know how to stop the “Bus is already connected” message from showing up when the engine starts?

I don’t get that message, it’s showing on the console?