On dedicated graphics, viewport only shows gray gradient, not objects

EDIT: Using the manufacturer’s graphics driver fixed the issue for me.

For some reason, when I run Lumberyard from my dedicated graphics card, it only shows a gray screen in the viewport, but when I run Lumberyard from my integrated graphics, it shows the correct scene. I could just run it on the Intel card, but it is obviously pretty slow. Is there any way to fix this?

Dedicated: NVIDIA GeForce GTX 960M

Integrated: Intel® HD Graphics 530

Using the graphics driver that was on Dell’s website fixed it for me. It’s over 7 months old, but oh well. Thanks so much!

Same exact problem for me. All drivers up to date.

Thanks for posting, I have been struggling to get the viewer to show anything, and was getting close to giving up.

Hi

Are you using one of the new Razer machines, by any chance?

If you are, installing the drivers from here might help:

http://drivers.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=590&pcid=589&nav=0,350,589

@matthewbuns @Gorgar Are you both on systems with two gpus (one integrated and the other not)?

A number of our field engineers got the LY Editor working using the nVidia drivers linked to on the razer support page above. Those drivers are version 359.30, which is not the most up to date version. I’d try that version of those drivers, if you haven’t.

Hi @matthewbuns

Sorry to hear you are having issues. Could you run dxdiag and attach the report so we can see more information about your system specs? In order to do this:

  1. Open the Start Menu
  2. Type dxdiag.exe and run the program
  3. Click “Save Al Information”
  4. Attach the text file to a reply in this post.
    Thanks!

Jordan

Hi again @matthewbuns

Could you also verify that your NVIDIA and Intel graphics drivers are up to date? You may want to check your laptop vendor’s support site for driver updates since they should have the most relevant drivers for your laptop.

Thanks!

Jordan

All drivers are up to date.

I had to put it on Pastebin because I couldn't attach the file.
Here it is: [DxDiag](http://pastebin.com/7raiMtaB)
Thanks!

@Gorgar might be, but not me. I have a Dell Inspiron 7559. I have updated all of my drivers.

After getting the Jan 2016 NVidia driver my problem was resolved.

Hi guys, i had the same problem, and I updated my all drivers and also the nvidia geforce expirience stuff . But still it doesnt work :frowning: My one is nVidia geforce GTX 960M, i downloaded the latest driver version 368.81 :frowning: can anyone give me a slution. Thank you!

2671-system-information.pdf (306 KB)system-information.pdf