On Mac error at startup : "System: There are still 2 registered allocators!"

Hi Community,

I was using lumberyard on PC since a while and kind of getting used to it, I like it.

But for different reasons, I have to work on Mac.

I made a brand new lumberyard install ( following https://docs.aws.amazon.com/lumberyard/latest/userguide/osx-intro.html and next steps up to Assets processing included, didn’t do yet the Shader processing )

I’ve then created my own gem, was building fine, but, when I am trying to start the game I got this error :

 AppleLauncher: Application descriptor file not found: emptytemplate/config/game.xml
System: ==================================================================
System: Trace::Assert
/Users/netboz/Devel/lumberyard/dev/Code/Framework/AzCore/AzCore/Memory/AllocatorManager.cpp(48): (140737145557952) 'AZ::AllocatorManager::~AllocatorManager()'
System: There are still 2 registered allocators!
System: ------------------------------------------------
System: AZ::AllocatorManager::~AllocatorManager() (+0x74) [0x10e1d5c74]
System: AZ::AllocatorManager::~AllocatorManager() (+0x15) [0x10e1d5ac5]
System: __cxa_finalize_ranges (+0x14c) [0x7fffe2a89178]
System: exit (+0x37) [0x7fffe2a894b2]
System: ==================================================================
Illegal instruction: 4

I’ve cleaned my lumberyard installation, reinstalled it, and simply tried to run StarterGame, but sti I am getting this error.

I’ve updated XCode, still the same.

I am running Sierra 10.12.6, with XCode Version 9.2 (9C40b)

If anyone would have a clue on this one, it would help me a lot, thanks by advance.

Could you post the entire log?

The portion doesn’t show the root cause.