PhysX Force Region not working with Cloth

I can’t figure out what I’m doing wrong.

Hello @wcb,

Thanks for your post. Sorry you’re having issues getting PhysX Force Region working with Cloth.

Before requesting further information, please try the following steps:

  • Open Tools → PhysX Configuration, scroll down to Wind Configuration section:


    These tag values are used to detect entities that are wind sources. Default tag values are ‘global_wind’ and ‘wind’ but can be edited if needed.

  • To set an entity as source of wind data:

  1. Add Tag Component to the entity, add tag with value equal to the one of values from PhysX Configuration → Wind Configuration
  2. Add PhysX Force Region component to the same entity, add World Space force

    Force value would be used as wind value by systems dependent on wind: particle effects, snow postprocessing effect, cloth etc.
  3. PhysX Force Region component requires PhysX Collider component to be presented at the same entity. Collider component of wind entity may be configured to affect certain PhysX rigid bodies or not to affect them at all via Collision Layer and Collides With settings.
  • In the entity with cloth, go to the Wind properties of the Cloth Component, untick the option Enable local wind velocity and increase the value of air drag coefficient.
    image4

If you still can’t get cloth to react to the PhysX Force Region, please provide more details of the steps you are taking.

Thanks,
Aaron

5 Likes

Behold! The curtains… they are alive! Thanks.

4 Likes

Any time! That is amazing! Great job!

1 Like