Player Session Rejected

Hello everyone,
I have a problem that the function ‘AcceptPlayerSession()’ throws an error.
I have checked this many times. The function is definitely passed the correct PlayplayerSessionId.
gameSession is created or joined successfully, aswell as the playerSession.
I see that in my game/server logs.


My gamelogs in game confirm

Same PlayerSeassion on aws web panel

This is the error on Server/Gamelift


[ServerModule] Connection String - psess-309b9c98-e4f1-4aa6-aa18-edd8bcd8cf08
[GameLift] AcceptPlayerSession request with playerSessionId=psess-309b9c98-e4f1-4aa6-aa18-edd8bcd8cf08
[GameLift] Player Session Rejected. AcceptPlayerSession Result : [GameLiftError: ErrorType=GAMESESSION_ID_NOT_SET, ErrorName=GameSession id is not set., ErrorMessage=No game sessions are bound to this process.]
[ServerModule] Disconnect Client from server - clientId : 2, playerSessionId : psess-309b9c98-e4f1-4aa6-aa18-edd8bcd8cf08

[ServerModule] On Client Connected - 2
[ServerModule] On Client Disconnected - 2

My fleetID=fleet-5aa4fe0c-b5d0-4277-870c-e1c3e96ffdaa
GameSeassion=arn:aws:gamelift:eu-central-1::gamesession/fleet-5aa4fe0c-b5d0-4277-870c-e1c3e96ffdaa/gsess-832594a9-edb5-4015-9c9e-dabb16452e5c

Hi @KKVision

Thanks for the detailed reproduction instructions. Seems like this issue has been blocking you for several days now, so I’m getting someone from GameLift to take a look at this for you in our backend.

James

P52099632

1 Like

Hi @KKVision

Looking at the ServerState.cs, it looks like that exception is thrown when gameSessionId is empty. That should only be the case when the onStartGameSession callback has not yet been invoked. Can you confirm if that callback was invoked in your server?

Brian

Well I kinda fixed the issue by deleting fleet, and switch SPOT to DEMAND using the same Build, and no change on my client code. I was planing on using SPOT so this is a bummer.

I tested again creating Spot instance with the build, this time I get the error Exception encountered: Unable to reserve a process on fleet fleet-3cb46ff2-0a67-4020-a0ae-5aec92cf19c5.

No errors on demand instance

Hi @KKVision,

There should be no difference on the GameLift Layer between SPOT and ON_DEMAND other than some special handlers for SPOT interruptions.

Could you by any chance retry creating a SPOT fleet and test again? It’s possible that the fleet recycling fixed your issue rather than converting to ON_DEMAND.

Thanks,
James

Yesterday i tried exactly this for testing recreating, SPOT for testing. And it did not work.
Tried again this morning and SPOT is working aswell. What I still don’t understand that my Player session got rejected earlier. So the issue kinda fixed it by itself. Without a change on my side.
Thanks for your help :slight_smile: