Playing a Video With Transparency in UI

I have followed the steps here on video playback, and was able to set up a script canvas to play the video on launch. I was also able to add an image with a Render Target SpriteType, and made sure that the target name matched the texture name in the Video Playback component.

In short, the video plays, and it plays in the UI fine.

The problem is that this video has certain transparent areas that show up as black on the screen (covering up whatever is behind the video). I have messed with the material settings, and with the color sliders in the UI, and the black area is still there.

  • Is this a limitation of ffmpeg? Looking here, it appears that ffmpeg cannot decode an alpha channel in a video for playback.
  • If not, what am I doing wrong?
    I have tried taking the frames of the video an putting them into a spritesheet, but that ended up crashing the editor (the final image was 120000x1280). Using a Flipbook animation is not an option for me in this case.

Hey @Roosevelt.Boyland, very sorry for the delays and troubles. I’ve pinged a few peers to check in on an answer for ya. Stay tuned!

Hello @Amonster_LMBR! Is there any update on this particular issue?

Hi @Roosevelt.Boyland,

It doesn’t sound like you’re doing anything wrong. The video player doesn’t currently support playing back video with alpha. This is something that we would like to work on in the future. We’re also planning on updating Flipbook animation to allow using a series of sprite files rather than one sprite sheet.

@Michelle Thank you for confirming! I am looking forward to that update.