Problems with animations made in blender that are imported into Lumberyard

Ok I’ve been at this for 3 day and it seems that the animations that I import from blender into lumberyard that i have made are distorted in some way. I’m not sure if this in my do or a bug. But Please help me so this is resolved.

Edit Video link to issue: https://www.youtube.com/watch?v=Ik5iSW_0xUA&feature=youtu.be

bad fps tho.

This is an image of an animation that is Animating in blender you see there is no distortion.

But Here is an image of the animation in lumberyard in animation editor Have no idea why this happens:

This is happening on all my animations example:

Here is a link to the blender and Fbx files Lumberyard team you are the best thank you for your help.

Link: https://www.dropbox.com/sh/gw5ibm5qimh7nyh/AAAzzJ-HbSTJglMmZeKQbgR7a?dl=0

@Ajia tyty im so glad you replied. I have tried everything. But What you said I think is the problem. The root is not at the top of the bone list. I will check this when i get home. Let you know if it works.

Hey @steveH,

Have you looked at our docs page about Best Practices around setting up the World Coordinate System and Root Joint for your asset?

Initially looking at the FBX file, it looks like you need to make some adjustments to your current set up.

  • Root joint is currently parented under another node called Armature. The root joint should not be under anything.
  • Root joint needs to match the orientation of your scene (Z-up by default with Blender if I recall correctly). Currently, it’s flipped upside down. It looks like the majority of your skeleton followed this so if you want to have a clean skeleton, you’ll need to adjust all of it.
  • There shouldn’t be any scale other than 1 for your Root Joint and your Skinned Mesh. The Armature node is set to 100 scale, which is also impacting the Root Joint. This should be fixed when you correct your root joint and skeleton.
    If you make those adjustments, then your character and animations should look more like what you have in Blender.

@Ajia can you help me out with this I have no clue how to fix this.

@Ajia I just want to say thank you. What you said fixed it.

@steveH

Glad to hear it’s working now!