Realtime Server Fleet Etag errors

Hi, I am experiencing a similar error to Realtime Server Fleet not Activating - but in my case it states the launch path is not working correctly. The launch path is set correctly when starting the fleet but the etag folders are creating a problem.
I uploaded my builds using the latest version of the cdk and the build is going to active but is not able to launch any game sessions.
I have logged onto the server directly and it seems that in my case there are two “etag” folders that have been created: one etag-0 and the other etag-12102bc463be3ae52848dca1be76e9b8.
When I manually launch the version in etag-0 it starts my server up. However, the version on etag-12102bc463be3ae52848dca1be76e9b8 states that I have insufficient permissions.
The build is defaulting to launching via etag-12102bc463be3ae52848dca1be76e9b8.

Hi @hines94, could you provide your failed fleet id? I can get the GameLift service to take a look at this issue. Thanks.

Hi @Junbo_LMBR, Apologies for the delay in getting back to you. The original fleet I was talking about I have deleted but I have created a new fleet with the exact same build which is producing the same error. The Id is: fleet-f787283d-2e65-4ca2-b69d-77f460d268e5

I believe theres a known issue using the CDK to upload a zip causing it to fail when its unzipped for the GameLift realtime fleet.

See Realtime Server Fleet not Activating for a workaround, which is frustrating, but theres some magic sauce to get the CDK to encode the file correctly.

Hi @Pip, Thanks for replying to the thread.
I have looked into your prior messages on Realtime Server Fleet not Activating and I can see that you have put on your last message to change the bundling option or isZipArchive.
However I have looked through my code and I can’t see an option to change anything like that:

            UploadPartRequest Request = new UploadPartRequest();
            Request.BucketName = Params.GetBucketName();
            Request.FilePath = Params.GetFullPath();
            Request.Key = Params.GetKeyName();
            WaitingUploads.Add(S3Client.UploadPartAsync(Request));

The upload part request doesn’t seem to have too many built in options? Do you know how I can set these properties?
Thanks,
Jack

Based on your code have you tried setting the objectmetadata?

ObjectMetadata objectMetadata = new ObjectMetadata();
objectMetadata.setContentEncoding("gzip");
objectMetadata.setContentType("application/x-gzip")
     
....
Request.SetObjectMetadata(objectMetadata);

I don’t have a good repro with the CDK et al. but it will be something like this to force the encoding to be handled correctly.

You can probably check the