Selecting a material in the material editor causes FPS to drop from 250+ to less than 10

When I open the Material Editor and select any material, my FPS in the perspective viewport drops from 250+ to less than 10. This occurs only when I select a material, and not just by opening the material editor. If I close the material editor or deselect a material, my FPS returns to normal. This happens in any level and with any material. The following message fills the console when the material editor is open with a material selected, though I do not know if it is necessarily related - “Failed to store dynamic module information, increase size of AZ::Debug::SymbolStorageDynamicallyLoadedModules.m_modules to maintain stack tracer functionality!”

http://imgur.com/a/4x7Ui - I uploaded a series of screenshots to Imgur that show the problem. I wasn’t able to upload them to the forum because of the 1KB limit on attachments/images.

Any help us greatly appreciated!


Other possibly related posts that I have reviewed:

#1 https://forums.awsgametech.com/t/particle-material-editor-cause-severe-performance-drain/1486/1

Unlike this user, I have had the problem in v1.6, v1.7, v1.8, and it persists in v1.9. My FPS also doesn’t just drop to about half, it goes to about 1/25th.

#2 https://forums.awsgametech.com/t/issues-with-material-editor/1854/1

Possibly a known issue… no solution provided.

#3 https://forums.awsgametech.com/t/engine-crashes-when-i-open-anything-in-material-editor/1129/1

I am using most up to date DX and all video drivers are up to date.

#4 https://forums.awsgametech.com/t/textures-in-paks-cannot-be-chosen-in-material-editor-assetcatalog-xml-slowing-down-editor/1121/1

I am not using any texture paks.

Yikes! Sorry for the troubles - let me see if I can get some answers for you on this topic :slight_smile:

Hey @Yeshua, looks like this is a known bug on our end. Should see a fix in the upcoming updates :slight_smile:

@Aman_LY Thanks! I appreciate the quick update. Can you provide a little bit more of a commitment on this? Some related posts seem to suggest that this was a lingering issue since as far back as v1.5. If you can provide a hotfix or workaround that isn’t baked into a full build that is acceptable as well. I’m sure you can understand that this has a real impact on workflow productivity, given that the material editor cannot be used at the same time as any other window. Thanks again!

Today I had some luck improving this situation by closing the asset processor, closing the editor, then re-opening it. Either the asset processor was in a bad state or maybe the debug version of the asset processor was running (launched from the debug version of the editor earlier in the day maybe). It doesn’t completely solve the problem but it got a 10s of fps better.

Hey @Yeshua, terribly sorry for the delays — I know this has a huge impact on your progress. It looks like the fix for this bug should be coming in 1.10, which I’d expect to be announced very soon! :slight_smile:

@Aman_LY

Any update on this? I can’t use the material editor right now. I can’t really work on a game without it. I’ve moved on to character creation, but I’m seeing the same problem in Geppetto - apparently any time a second renderer is opened, it causes the problem. I can’t constructively use Lumberyard without the material editor or Geppetto.

I need a workaround, a patch, or a commitment for the date of the next release that will include the fix.

@Amonster_LMBR Thank you. We are all looking forward to 1.10!

Thanks for the tip, new_user_987. Unfortuinately I wasn’t able to reproduce the FPS gain. Hopefully 1.10 will be out soon.

Hey @Amonster_LMBR, unfortunately v1.10.0.0 did not resolve this issue for me. All symptoms remain as described. My workflow is crippled by sub 10 FPS. The entire UI is sluggish, not just the perspective window. It makes changes to materials very slow and frustrating, and it is almost meaningless to try to use Geppetto.

Please advise on a fix. Thank you.

@Binky_LMBR - FYI

Sorry for this experience @Yeshua — I’m checking in with the team about this. Will update this thread as soon as I hear back!

@Amonster_LMBR @Binky_LMBR

Hello, It has been almost two months since I reported this issue and I have not received any support. Again, v1.10 did not fix the issue. As I have been trying to continue working in Lumberyard, I’ve tried to work around this. Today I discovered that this also affects the UI Editor screens as well.

I need some help here guys. I am burning time trying to make progress on my project and this is really hurting my productivity. I’ve sent you a DXDiag and I am available to answer any questions and provide any information you need. Right now I’m having to chase you down to get any response on this, and I still don’t have any fix or soltuon.

I do have Starter Game Sample installed. If you’d like, I would be glad to show you the issue via screen sharing.

Error messages impacting frame rate -

The error message shown in the screenshots, “Failed to store dynamic module information…” went away with v1.10. However, I have taken a note of this just incase it resurfaces for any reason and I will try the workaround you described above.

Could you please provide us with a screenshot of the Material List -

There is a screenshot of the material list in the imgur post? Do you need a screenshot that shows the materials differently? Also, this occurs with any project I have used including Starter Game, Samples Project, and my own projects, all of which have many different materials.

Does this issue occur when you select multiple individual mats -

The problem occurs when I select multiple individual materials.

Are the results the same when selecting multiple mats -

The results are the same when selecting multiple materials.

Any sub-mtls within the Mat seen in the example image -

I don’t understand your question.

Also, remember, this happens with the material editor, geppetto, UI editor, the particle editor… it happens any time a second rendering window is visible. There is one embedded in all of those windows.

Hi @Yeshua, I understand that this is an incredibly frustrating situation for you and I’m tremendously sorry for such a negative experience. I am on the hunt to reverify this issue, however, I am rather curious about something… do you happen to have multiple Lumberyard versions installed on your machine? Let me know at your earliest convenience while I dig deeper on this weirdness. Again, I’m terribly sorry for this and thanks for your patience!

Oh wow, sweet!

Alrighty, have you launched Lumberyard / “editor.exe” from your Dev folder as admin yet? I’m curious to hear about the results – I’m attempting to repro this on my end as we speak :slight_smile:

Got it - so I just tried to repro this issue on three machines and all worked as expected. I did notice on each machine that when selecting materials the FPS does stop and or drop for half a second, but ultimately ramps right back up to speed. With that in mind, I wonder if you have Starter Game Sample installed on 1.10?

@Amonster_LMBR

Thanks for checking in. I do have multiple versions.

1.6.0.0

1.8.0.1

1.9.0.0

1.10.0.0

I do not normally launch the editor as Admin, but I just tried it and the issue is still present. I confirmed the asset processor was also running with elevated privileges as well.

Most engaging - my apologies as this seems to keep dragging on…could you please verify the build # by going to Help > About Lumberyard in the Editor?