Server process exited without calling ProcessEnding(), exitCode(1)

Hi, I can’t create a Linux fleet for my Unreal Engine build.
The same build compiled for Windows Server works without problem, but for Linux I have this issue:

I think it could be an issue related to my game logic, so how can I see the logs?
To avoid uploading the build on AWS I would like to run it in an AMAZON_LINUX virtual machine.
Is it possible? how can i get one?

Hi @lostwoods91, you may want to remote into the GameLift fleet and start your server manually to check the log:

Thanks, Junbo, I’ll give it a try!

Hi, I tried executing my game directly from the instance and it seems that it misses some libraries:

./BiscaServer: /lib64/ version 'GLIBC_2.29' not found (required by /local/game/Bisca/Binaries/Linux/../../Plugins/GameLiftServerSDK/ThirdParty/GameLiftServerSDK/Linux/x86_64-unknown-linux-gnu/
./BiscaServer: /usr/lib64/ version 'GLIBCXX_3.4.26' not found (required by /local/game/Bisca/Binaries/Linux/../../Plugins/GameLiftServerSDK/ThirdParty/GameLiftServerSDK/Linux/x86_64-unknown-linux-gnu/

am I supposed to add them by myself in the installation phase?

GameLift runs on Amazon Linux 2 or Amazon Linux 2018 instances.

Firstly, use Amazon Linux 2 (its easier to work with, more up-to-date, connected to better repros etc - 2018 is basically EOL).

Secondly, yes you need to setup your to add what is required (for example the glibc version you compiled against)

You can work with the docker image if its easier:

You can see a little how lumberyard sets this up (but you need to obviously install the dependencies you require) here:

Thanks, @Pip, I followed your advice and installed Docker and an Amazon Linux 2 image on my Windows machine.
I manually tried (for exercise) installing glibc-2.27 and I had success.
I tried repeating the process for version 2.29 but seems that make installation is too old.
I tried upgrading with yum install make, upgrading yum, rebuilding yum db, but unsuccessfully.
does Amazon Linux 2 images support make version newer than 3.82?

my ubuntu image successfully updated make to version 4.2.1-1.2 instead.


Thanks everyone, I solved by compiling my library with an older version of Ubuntu (18.04) as Flopperam suggested!