Server process exited without calling ProcessEnding(), exitCode(-1073741515) Unity Empty Project | Tried everything

Hi!
First of all, thanks to see this topic!
My problem is: I have this error in the Events tab of the Fleet (fleet-71d79467-bc74-4029-9479-df6799cadeb5). I tried everything:

  • My Project and an Empty Project (Only with GameLift Server and Client SDK + my server code (Tried executing nothing apart of GameLiftServer))
  • Works perfectly in Local
  • I can’t enter remotely to any Fleet, the console say “Not found”. Tried in every state (Less Active, obv)
  • The Fleet still with this error until Fail/Error
  • I restarted the Fleet +10 times with different configurations
  • Tried Server Build(Headless) and regular build

What I have not tried:

  • Install some library (.Net, vs, DirectX…). But in theory it’s not necessary…

I thinks it’s everything, I will edit if not.

Thanks in advance

Exit code ( -1073741515) I believe maps to STATUS_DLL_NOT_FOUND so you are missing a dependency when running on GameLift; the following below assumes you are running on Windows

First Steps (check your assumptions):

  • Check whats in your install.bat ensure it installs anything you depend on ie Visual Studio redistributables
    • Check your build includes all locally packaged DLLs you require
  • On the fleet events tab you can get the log of running the install.bat, check this to ensure it completed what was asked.

Second Steps (remote to the fleet)

  • When you create your fleet ensure you open the RDP fleet port ie " "FromPort=3389,ToPort=3389,IpRange=<your ip address>,Protocol=TCP"
    • If you don’t open the RDP port by default, it can only be added on fleets which are in ACTIVE or in ERROR
    • I always get the address as AWS sees it by going to an EC2 security group and editing the inbound rules.
  • Then you can remote into the fleet using the instructions here
  • Then try launching your executable locally and see where it fails.

GameLift gives you a fairly minimal windows instance or Linux instance, you need to ensure your build and/or install.bat installs everything required for your binary to run.

Thank you so much!
The documentation isn’t good enoguh to be honest, worked perfectly.
The issue was the c++ redistributable.
For anyone with the same error, over the internet everyone says “With Unity you don’t need to install nothing”, it’s a lie (At least in Windows Server 2012).
I’m using Unity 2020 with GameLift Server SDK. Install c++ redist.