Server travel in UE4 with gamelift

Hello, i am developing online multiplayer game in UE4 with dedicated server and i use gamelift as backend server. I try to change maps with server travel command in UE4. It works properly when i test it with gamelift local, but when i test it in fleet new game mode don’t load with new map. Any idea why it is the case ?

Hey @Zeynep_Cam

I’m not aware of any issues with calling the UE4 ServerTravel command from a GameLift fleet.
A couple follow up questions to try to figure out whats going wrong:

  1. Are you able to see any server-side logs indicating an issue? Or does the server travel to the new map correctly, and the issue is with clients following to the new map? If so how do the clients behave?

  2. Which version of UE4 / GameLift UE4 plugin are you using?

  3. Can you provide me with a fleet-id for the fleet experiencing an issue? This can help with further debugging of the fleet configuration as well as attempting to reproduce the result it necessary.

Thanks! Hopefully we can get this issue solved for you soon.

Thanks for reply. It turns that my problem is not about game mode, but for some strange reason my client act like server. I figure that when my client cannot execute remote in switch has authority node. It executes authority part of the code. I am using UE4.25.4 and gamelift with blueprints (aws) plugin. My fleet id is fleet-32ea6d5c-3cb6-4cf4-88a4-960150e98ccb, however since i use free tier, i need to remove it and upload new fleet for test purposes so it can change.

I solved my problem by call init sdk and process ready functions in new game mode.