Sky Clouds: Fails on export to engine

Platform: Lumberyard 1.27

While playing around with starter game, i added the sky clouds. It works fine in the editor but when i click on export to engine i get an error message telling me the compile to level.pak failed. If i remove the sky cloud, it works.
The logs is saying Exception Access violation.
Does anyone know if i am doing something wrong or is it a bug?

Log File.
level.pak-1862114299-16234.log (5.9 KB)

Editor view

Console view

I tried export to engine with Sky Cloud in the level and got same error. If you remove your Event log Detail filter to show all messages, it seem to point to CouldComonentRenderNode destructor. Looking at similar render nodes, it looks like it should check that engine initialized before calling freeRenderNode, adding that and rebuilding got rid of the error for me:
image

2 Likes

I just tried it and it works now. Thank you :slight_smile:

1 Like

Howdy, Niklas! Iā€™m glad koolean was able to get you up and running. Just wanted to let you know that we have a bug logged for this issue. Thanks for the heads up!

1 Like