[Solved in LY 1.25] AI Bug and AI Crash in Script Canvas in Lumberyard 1.23 & 1.24

Hi LY team,

I found a bug & a crash about AI System & AI Script Canvas in Lumberyard 1.23.

Please see :slight_smile:

Please Fix this bug/crash…

Thanks

NOW , Why I can make AI Script Canvas in 1.18 but I can not that in 1.23 ?!

Hi LY Team,

I tested in LY 1.24 , The crack has been fixed , but the bug still exists!

I did all the steps correctly in LY 1.24 but Does not work! BAD BUG! :triumph: I’ve done this before in LY 1.18 and even made video tutorials :sob:



Hi, I’ve filed a ticket for the team responsible for this component.

1 Like

I verified Starter Game in LY 1.24**.0** , this bug/problem is for Ctrl+E(Do not work Export to Engine AI AREA), I do not tested this for LY 1.24.1 , Do you know that this bug exist in LY 1.24**.1** ??

Hi AhmadKarami,

Does this issue still exist in 1.25?

1 Like

Hi @lmbr_Saulty :rose:
sorry for delay , I want test , so I insert the result here today :slightly_smiling_face:

Hi @lmbr_Saulty
I tried A LOT, I tried different methods but the result is nothing , looks like does not work! but I think , I am wrong, I using starter game 2.0, how to implement AI-Robot ? Please see entity inspector in AI_Area Entity , also I tested my script canvas file in LY 1.18 does work , but when I tested in LY 1.25 , does not work! :slightly_smiling_face:

It should be noted that because the API have changed, there are definitely some things I do not know , I suggest to lumberyard team step-by-step make video tutorials will certainly solve this issue, especially about the behavior tree and target coverage points. :rose: :pray:

SOLVED AI Navigation in LY 1.25 :star_struck: :heart_eyes:

THANK YOU SO MUCH FOR HELP @lmbr_Saulty @petrocket @WashedUpStudios :rose: :pray: