[Solved] Material Editor (Filter), not working?

I trying change filter of texture and any time no changes :frowning: Need see original image with pixels without adding filters and anti-aliasing.

p.s. Lumberyard 1.23.0.0

You’ll want to right click the texture in the asset browser and click “Edit Texture Settings…” and then disable mipmaps and filtering there to get a cleaner pixelated image if that’s what you want.

No Changes

Did you disable the filtering? Maybe try changing the filtering and leaving mip maps on.

How disable the filtering ?

How i understand filtering apply only wen texture rendering, and this setting sets in Material Editor (Shader).

image

Nothing, problem not in import settings. Problem In render. Texture rendering in scene, shader apply filter and not looks in shader settings, and you can’t switch that filter :(.

Found this, and nothing. Date - Nov. 2017

I don’t know. I hope the lumberyard team takes note of this bug.

1 Like

Hi there! Thank you for the feedback. We’re looking into the issue and will get back asap!

1 Like

You can change the cvar r_TexMinAnisotropy to 0.
The current value for this cvar is set to 16 in \dev\Engine\Config\CVarGroups\sys_spec_Texture.cfg file with highest setting.
Any none-zero values will force the material textures samplers to use Anisotropic filter instead of filter you selected in material editor.
By setting it to 0 will let the material using whatever filters specified in material editor.

4 Likes

SUPER !!! All Worked. Thank you all for answer and yours time :slight_smile: