Stuck at Connecting to Asset Processor

Hi all,

I’m attempting to run Lumberyard on a Windows 10 Amazon Workspace(Graphics Bundle). I’m getting stuck right after setup at “Connecting to Asset Processor”.

I’ll attach screenshots of the error.

workspaceslumberyardeditor.pngworkspaceslumberyardeditor2.pngworkspaceslumberyardeditor3.png

I’ve tried a lot of the suggested fixes like the below: Unable to connect to the local Asset Processor

But running AssetProcessor and AssetProcessorBatch doesn’t seem to do anything. No AssetProcessor process actually ever gets started according to what I can see in Task Manager, and Windows Sysinternals Process Explorer.

There’s no local Cache file in /dev/ for me to delete cause the AssetProcessor doesn’t ever seem to have started successfully.

I turned off the Windows Firewall in case there was an issue with networking on the local interface. (I also tried with the firewall on with rules allowing the documented ports through.)

I’ve tried uninstall/reinstall, I’ve also tried this on another separate windows 10 workspace and I’m running into the same issue. Asset Processor just appears to never get started, even when I attempt to start it manually.

Kinda stumped here, anyone able to help? Or encountered this before? Are there any debug logs for editor crashes I can find somewhere that might help? This worked fine on my Windows 10 local machine, same Lumberyard build.

Thanks,
Rob

Hey @RobDev, apologies for the troubles – let me get some assistance for ya on this topic :slight_smile:
Stay tuned!

Hello @RobDev,

Have you tried running the Asset Processor as an Administrator? I experienced the same issue when I was using AppStream 2.0 as well.

Let me know.

Thanks!

Thanks! Appreciate it :smiley:

So, I decided to just straight up try running the Lumberyard Editor as an administrator hoping that the permission would be inherited by the Asset Processor, and it worked :smiley:

Thanks for the help!