Substance import "Failed to create substance"

4310-javoire-sbsar-test.zip (1.41 KB)javoire-sbsar-test.zipHey, I’m trying to use the Substance Editor to import a substance from Substance Designer. However, all I get is “Failed to create substance” with no more information. I’m trying to increase verbosity of logging so I get something to debug, but setting to level 4 doesn’t seem to have an effect on the editor console: http://docs.aws.amazon.com/lumberyard/latest/developerguide/system-crylog.html#system-crylog-verbosity

I can’t upload the sbsar file (EDIT: it’s in a zip now) so I have a screenshot of a very simple test substance. Using, to my knowledge, the correct process for lumberyard (spec/gloss, normal alpha etc). Following this http://docs.aws.amazon.com/lumberyard/latest/userguide/mat-substances.html#mat-substances-creating and https://www.youtube.com/watch?v=L-Gch25vsdI.

Versions:

  • Lumberyard 1.8.0.1 Build 369592
  • Substance Designer 6.0.2 Build 20117 - Trial version.
  • Windows 10 Version 1607 (OS-version 14393.1066)
    Any hints on what I can do to debug this?

Thanks!

EDIT: Attached .sbsar in a zip file

No worries, I’m sure it’ll work out. It’s beta after all :slight_smile: Or it’s me making some mistakes. Thanks for you answer :slight_smile: I’ll stay tuned.

HI @javoire, sorry you’re having these issues. I’m checking with the team to see if they have any thoughts. It’d be interesting to see if anyone in the community has any thoughts as well.

I have the same problem can’t identify what is going on

I’ve added your comment to the ticket. Sorry you are experiencing these issues as well.

Sorry for the delay on this. Do you get the same dialog with the samples, or only with a newly generated sbsar?

Also are you using a trial or full version of Substance.

Hi @javoire,

We hope to have some updates and fixes for the Substance integration soon that may address this soon. Until the update is ready, please try removing the Height output and see if it works. I suspect what is happening is the substance importer doesn’t like either the Height or Specular outputs and I think maybe it’s the Height one.

Hey everyone,

I was having the same issue in 1.10 as @Lucian and @javoire were in their versions. For me, my normal map was preventing LY from importing the substance correctly. What worked for me: changing the Alpha Channel Content on the Normal node to Fill Alpha with Input.

I assume this worked because LY needs the gloss map in the normal map’s alpha channel and having the Alpha Channel Content set to Force Alpha To 1 might have been interfering with that.

Is this still an issue or has a patch come out to fix it.

I just hung the hat for today because I finished making a substance, took a very long time with it, and then was not able to import it into lumberyard.

Same message as reported above. If a patch hasn’t been released to fix what you’re referring to then I’ll just try removing one of those outputs.

Thank you for your time.

You might also try messing with your alpha channel content in your normal node, if you have one. Changing it to Fill Alpha with Input allowed me to import.