Terrain is hide in LY 1.24 for make New Levels

Hi LY Team,

My Hardware & My Software

OS : Windows 10 - 64 bit

Game Engine : Amazon Lumberyard 1.24

CPU : Corei7 - 4GHZ

GC : NVidia GTX 760 - 2GB Real

RAM : 16 GB

HDD : 1 TB

Reproduction Bug
1-Opened launcher (SetupAssistant.bat)
2-Switch Starter Game to SampleProject via Luancher
3-I make a new level
4-Terrain is hide! I can not see terrain! :triumph:

1ne Tip: When i open Audio_Sample level , terrain is exist! I can see terrain! :sob:

I Made a NEW LEVEL


Audio_Sample LEVEL

Please Fix it :pensive:
Thank you

Hello @_AhmadKarami The terrain now needs the new gem Legacy terrain enables to see and use terrain in this version. In a new version I believe a new terrain is in the making.

1 Like

Hi @WashedUpStudios
Thank you but I looked, the point is that it is terrain gem enabled by default.
I don’t think Rebuild again is desirable for many game developers.
This is a vision of immigration strategy, and I have already outlined some of the strategies,I have been using lumberyard since 2016.

Although Legacy terrain gem is active by default, but bug terrain is exist in ly 1.24, the problem is elsewhere …

I found it, you add a terrain in under game - terrain - generate terrain. Then after you generate your terrain you have to go onto a new or different level then back to the newly generated terrain level and your terrain should appear.

I did it , but disabled Generate Terrain Option , I insert shots :pleading_face: :flushed: Does not Work ,I think , this is a bug terrain :sob: :sob:



Hi! In LY 1.24, Terrain has moved out of the New Level dialog and has become a “Level Component”. To use it, you’ll need to do the following:

  1. Make sure you have the Legacy Terrain Gem enabled. (From the posts above, it looks like you already do)
  2. Run the Editor and create a new level.
  3. Go to Tools->Level Inspector to see the inspector for level components.
  4. Choose Add Component -> Legacy Terrain.

At this point, you should see terrain show up.

Optional: If you want a terrain size other than the default 1024x1024, go to Game->Terrain->Resize Terrain.

To address some of the other comments above:

  • Once you have the Legacy Terrain component added, you can go to Tools -> Terrain Editor -> Tools -> Generate Terrain to generate new terrain height data. Before you do this, you will probably want to go to Tools -> Terrain Editor -> Modify -> Set Max Terrain Height and choose a number like 200, as the default of 1024 works better for certain types of imported heightmaps than for generated terrain.
  • The “Generate Terrain Texture” option is a different type of generate command - it is used to regenerate the game-ready terrain macro color texture, it doesn’t create any new terrain content.

Hope this helps!