Texturing works but not close up

My textures are showing up under texture layer painting dialog, but when I try to paint a given texture on terrain it works seemingly, but close up looks like this.

What setting am I missing ? :wink:

See image show below:

ty

Gotcha, I see the step we are missing.

The Terrain Texture Layer doesn’t assign Textures to a Material, it lets us arrange layers, set Splat Maps and define variable for our texture layers. Using multiple layers with the same Material will lead to some big painting issues.

Also the Grey box in the Texture Layer Editor is a preview color only, it doesnt effect the color of your textures when we paint them.

There is another Editor called the Material Editor that will let you create new Materials and assign Textures to them. Open the Material Editor by clicking View -> Open View Pane -> Material Editor in the Menu or by clicking the Icon in the Editor Toolbar.

In the Material Editor Navigate to or create a new folder for your Materials (I’m unsure as to the ‘best practice’ place to put new Mats) Then click the Create New Material icon, this will create a new Material with no textures applied. Here you can either assign Texture maps to your material or leave them blank for flat color. Either way it is important that you create new materails and assign new materials to each layer in order to paint.

Let me know if that clears up the issue!

Thanks!

I found a tutorial that did say, delete default, but I think its an OLD tutorial, as you can’t delete it without first adding a new texture.

All of your textures look flat grey, where mine are similar in color but actually show the ‘detail’ as such, did I choose the wrong texture file ?

I also do not have split maps, but thats because I’m not using world machine or whatever you may be using.

My machine lags hard for at leat 1/2 a minute when I try to world ‘fill’, what would cause that ?

Anyway I"ll try doing it over again hope it clears the default layer, I think the team should fix that :wink: ( I have newest engine )

Does anyone know why this occurs ? I"d rather have as well, someone from lumberyard tech team respond to this so I know this isn’t something more pervasive :wink:

ty!

Hi @cajunctionAI

I have encountered this issue in my own work. As near as i can tell it has to do with the relationship of your layers in the Terrain Texture Layers tool. It seems like the engine is tying to render the layer in order from top to bottom with the top being a fill of the default texture.

  1. Delete and remake your layers in the Terrain Texture Layer window

  2. Re-arrange your layerd in the Terrain Texture Layer so that the default texture is at the bottom:

  3. Use the Flood button starting with the bottom layer of the Layer Painter tool in the Terrain Tab and work your way up.

Also, check your render settings. Could be a camera thing.

Please, let me know what works!

Thanks!

Just loaded my old file that had this issue:

Delete the default layer in the Terrain Texture Layer and re-build your materials in the Material Editor. Sometimes the material will try to reference the default texture layer so you will need to re-build your material in order to clear that. I had a couple of layers here that were doing it:

So I deleted the default, rebuilt my materials, re-assigned in the TTL and painted/flooded the scene. Fixed it right up:

2921-level-clean-01.png

Hope this helps!

Hi and thx for reply,

I already basically knew all of that from watching youtube video and amazon docs, but thx for verify ( that I didn’t really know per se) that texture layer editor is just that.

I’m getting closer, but I"m seeing alot of very very low fps.

Is my computer too slow for this atm ?

Terrain is 8x8km square , and I’ve applied 3 texture only atm, but I"m having alot of trouble getting the ‘layer’ altitudes right :frowning:

I do have a quad core PHenom II x4 3.2ghz with GTX 950 2gb, is that not enough ?

The low fps are really hurting my dev atm, if not for that I could get much further much faster.

What are you system specs if mine are too low to use lumberyard ?

I have no trouble in ue4, but the I have only one texture applied to terrain , that is the same size as here, same terrain ( testing here)

ty

This forum is really frustrating, when are they going to fix it ?

I made a post, had to log in, but it didn’t 'keep ’ that post , so now I have to do it all over again.

Very poor.

Anyway, texture editor, says , under material column, ’ materials/material_default_terrain ’ .

I can’t change that, so I"m wondering if thats what you were talking about, as it always says that no matter what texture I change to.

ONe other thing,I do not want to Flood entire terrain, that was just a test, but I may want to later of just the ‘bottom’ texture, prob. default behavior and it makes sense.

Also what do you mean, re-build textures in material editor ? I see no way of doing that, or did you just mean re-do settings, but I see no reason to as they all look fine as is, at least given one youtube tut I saw for lumberyard editor.

Also, I can’t ‘delete’ the terrain to start over, as having loaded terrain, parts of it are covered in what looks like a ‘normal map’ shades of purple and such that those maps represent.

Lots of issues atm, that I never had to address as I was just testing out creating terrain.

HELP lol :wink:

Sorry to top this off but I can’t go any further here until I can get this working :wink:

I have a very large world in ue4 and zero of the problems I’m having here.

I’ve got the texturing working much better, but I can’t flood fill even one texture without it starting to lower me down to 3 or less fps as I start to navigate around world ( no character yet just camera work).

I know its not my computer given ue4 does just fine, so what might this be ?

I can’t work on this engine until I can figure this out,sorry.

cheers

Well UGH, that didn’t help at all.

Made new terrain, 4096 1 MPT, loaded terrain, applied ONE texture, forest grounds tiff, filled it, and took longer than I think it should have, and even though I had it set to 0 … 5 and 5 degrees for fill values, trying to move camera around level had me lagging hard at 5 fps again.

What am I missing ???

Are the other threads right afterall, that this engine in beta is lagging hard with just about any hardware ?

Sorry to say, but if so, ue4 is a no brainer.

Hrmmm, Its not your rig. Yours is slightly better than mine. I’ve got a 6-core Phenom II running GTX 760. Could be the Terrain patch. I’ve been running patches around 4k for single levels. Are you running your terrain patch at 8k with no terrain multiplier?

Just under Heightmap Resolution, the dropdown for Meters Per Texel multiplies your heightmap resolution for better performance with a slight drop in map res.

2858-mpt-01.png

Export your Heightmap and then make a new level with a 1k heightmap at MPT of 8, a 2k heightmap at MPT 4 or a 4k heightmap at MPT 2. This should give you an 8k map and address your framerate issue.

2859-mpt-02.png

To Export your Heightmap open the Terrain Editor by clicking View -> Open View Pane -> Terrain Editor. In the Terrain Editor click File -> Export Heightmap