The update was very bad!

2 Likes

This was said in 2017, under this official video! by AWS Game Tech :
We believe 2018 will mark a new beginning for Lumberyard. With our overhaul of legacy systems near complete (10 out of 12 major systems changed), and seven brand new systems in place, it’s time to accelerate towards full release.

NOW IS 2020 … When Amazon Want publish Final Version(Prime Stable Verion) ? I do not Know!

I’ve tried to tell them how poorly the project is currently perceived. I don’t blame the devs - I’m sure there are several excellent folks working on it. But the whole thing smacks of a lack of leadership and commitment from further up the foodchain.

1 Like

Hi, I understand that you feel frustrated but rest assured that we are committed to continually improve Lumeryard. Some very cool things are in the works so keep an eye out for future announcements!

2 Likes

Hi everyone! we all can see there are a few issues with LY, but the majority end in the waf and building a project for a few hours. And that should be changed to C Make. When it does it will be a new chapter for LY.

Hi Itachi999,

Thank you bringing this to our attention. We have reached out to the author of the video to get more info and we are actively investigating the issues discussed in the video. In the meantime, if anyone is encountering a similar issue, let us know on the forums and provide details on the following:

  • Your machine specs/setup

  • Version of Lumberyard you are using

  • Error logs

Thanks

1 Like

Hi @lmbr_Saulty I was wondering if you know why the asset processor is using so much ram for a character? I have 16 gb of ram which seems like plenty for a lot but with my character it goes right up to 100% and it all freezes up. no error just not sure why? Thanks

I think it will take a bit more than that to start the new chapter for Lumberyard, but I really do hope that new chapter comes.

I hope to pop in here one day and see some signs of renewed commitment from Amazon, and big developments that make me think, “Now that’s more like it!”

1 Like

Hi, can you send us the asset processor logs for the character so we can take a look to see what happened?

Thanks!

CartoonTest2.fbx-1847548697-23406.log (10.0 KB) CartoonTest2.fbx-1847548697-23410.log (10.0 KB) CartoonTest2.fbx-BD8BF658-9485-4FE3-830E-8EC3A23C35F3_createJobs.log (315 Bytes)
Those are the three logs that came with it.

Perhaps the lumberyard team could add the option to auto send a error logs with user system specs when there are build errors or other errors. that could be analyze for common problems to make the engine more stable. Also I would think a lot of errors would be attributed to not having all the correct visual c ++ components enabled and a check to make sure visual studios is set up correctly would be helpful. I read a forum post about getting lumberyard to build a while back and it had people enabling things in visual studios that weren’t enabled by default.

1 Like

For me all looking good, update worked and project from previous version set on new version, correct and work. I worked with Lumberyard only in c++. And rarely open the Editor. Every time wen i read release notes i see big VERY BIG difference with source code. If in release notes says about 100 improvements and changes, in source code its thousands. I work with Lumberyard from 1.02.00 version, and on this moment this is powered and strong game engine. Yep have some problems, but, and version is beta. I hope Lumberyard team will go like and before. Thanks to AWS Lumberyard Team.

Hi @WashedUpStudios,

Thanks for attaching your AP logs. Did the fbx in question eventually finish processing, or did it just sit in the “in progress” state forever?

1 Like

Hi @Hawkeye it never finished but I found the problem. It has blend shapes for the face, which do not like to import well into Lumberyard. I removed all blend shapes from my character and reimported it, and it imported nice and easy. Hope it is a bug, and can be fixed, because it never showed up in the asset processor or logs.

Hi @WashedUpStudios, I’m glad to hear your issue has been resolved, but that is unfortunate to hear about the blend shapes. I will pass that info along to the rest of my team. If you don’t mind my asking, what program did you export your fbx file from? Is there any info you can tell us about the blend shapes that might help us reproduce the issue accurately?

Also, just to confirm, did you see this issue in version 1.24 or a previous version? Has this been a recurring problem, or is it new?

It is a new issue, and I am texturing in blender so it was exported from Blender, and the model is a autodesk charactergenerator model that I purchased.

Hi @WashedUpStudios ,

Thank you very much for taking the time to send us this bug report. I have cut an internal ticket for the Asset Pipeline team that is being tracked as LY-116086. If you have any other issues like this feel free to let me know!

1 Like

hello…
Whatever I did, I couldn’t do.
What’s the problem?

I first worked on version 1.14 and have had fewer problems so far…
But version 1.24 caused me a lot of problems

Hi @Itachi999,

The error you are seeing is due to a malformed command. In this case, you probably want to be building “-p game_and_engine” instead of “-p game”.

1 Like

Hi @Hawkeye Yeshua and I were trying to figure it out and he got it to import, but he needed 90 gb of ram to import one character into Lumberyard. He figures it has to do with blender blendshapes, I was just giving a checkup on this issue.

1 Like