Touch Bending not working

I’ve gotten this far:

image

However, when I walk into it, the limbs do not move. It doesn’t seem that the collision meshes are reacting to the player at all.

Hi,

Can you provide us your Entities setup? Are you using Cryphysics(Physics Legacy) or PhysX?

Thanks!
Alex

I’m using physx. Those wireframes are the collision meshes which are drawn using physx debug gem and enabling “physx_debug 1”.

I just followed the directions outlined in the documentation for creating touch bending. It’s possible the touchbending just doesn’t work with physx yet because physx isn’t integrated at all, it seems, into the vegetation system. I can’t get any collision at all and I think that might be relevant.

I figured it out. My player was on “PlayerLayer” collision layer. When I set it to default it now works fine!

Should probably be noted that you need to be on default layer for touch bending to work on physx (I don’t know about legacy physics).

That’s kind of irritating because now I can’t put my player on its own collision layer.

Hi wcb,

You don’t have to use Default layer specifically, you just need to make sure that your “Collides With” Collision Group is set to a Group that has enabled collisions with “TouchBending” layer.

Thanks,
Alex

2 Likes