Trouble running Lumberyard 1.19 with Nvidia 960m graphics card

The editor frame rate is very slow for a basic new scene. Other engines run fine, is there any settings I could try to improve the editor performance?

By basic, I mean a
new level/scene with a flat terrain and ocean. I know they are not the same
engine but as a comparison a similar new scene in CryEngine runs around 150fps
compare to 14-20 fps using lumberyard (lower when navigating).

Laptop Spec

  • i7-6700HQ 2.6GHz(Turbo3.5Ghz)
  • 16GB RAM
  • 4GB GeForce GTX 960M
    Are these specs to
    low to run lumberyard? If so no problem.

However if I should
be running the engine o.k. are there are any settings I could change to accomplish
this any help will be much appreciated.

Incredibly ODD :slight_smile:

I’ve heard of that occurring, but faik its never happened on my i5-3570, though it would scream anyway LOL

Nice system, my 3570 is going to need upgrading soon enough, still relevant but weakening ;)heh

Glad it helped ;_

Do you have lights in your scene those can cause problems depending on settings so check that.

Basic, can you elaborate pls.

M for mobile isn’t as fast as non M’s.,but I suspect you already know that, but with a ‘basic’ scene, without a ton of lighting should not affect that.

Your issue may be as simple as the ocean which for an M card might well be your bottleneck , and you can disable it as needed: , this shows you settings for ocean, altering/disabling some should help with your fps.

You can disable ocean entirely as needed,which should fix your current issues most likely:

See here-

Set it , at top right, to ‘start inactive’, and then you’ll know, but that should make a huge difference. I’ve never used a M card, but that should help- still need more info what ‘basic’ is to you, regarding your scene.

Hope that helps, let me know if not



Nvidia Manager auto selects lumberyard with integrated graphics as default. Changed to dedicated graphics and lumberyard runs great.

Even better with the ocean disabled. :slight_smile:

Thank for the help.