UE Linux Server Activation Error

Well, I uploaded the UE linux server to GameLift server with the sample install.sh

#!/bin/bash
echo 'Hello World' > install.log

Then after 30 minutes, it just went from Activating to Error state without any error log:

Fleet fleet-77194eb5-46b5-4bad-a4d5-d8f4fa9d0208 changed state to ACTIVATING

Fleet fleet-77194eb5-46b5-4bad-a4d5-d8f4fa9d0208 changed state to ERROR

I tried running my server on my ubuntu and I got this error message:

LogModuleManager: Warning: ModuleManager: Module 'SocketsWINDOWS' not found - its StaticallyLinkedModuleInitializers function is null.LogSockets: Warning: Unable to load SocketSubsystem module UNIX

Any idea on how to solve this? Do I need to install anything with installer script?

Best,

Hi-

GameLift doesn’t introduce any additional dependencies for UE – this is an issue w/ building on linux.

These docs should help:

https://docs.unrealengine.com/en-us/Platforms/Linux/GettingStarted

https://wiki.unrealengine.com/Building_On_Linux

Also, you will find that iterating will be faster and cheaper with GameLiftLocal – then you don’t need to spin up an actual fleet until you need to test at scale or move toward production.

https://docs.aws.amazon.com/gamelift/latest/developerguide/integration-testing-local.html

Hope this helps.

Yes, I agree this is definitely UE cross-compiling issue. Might be a bug in their tool chain. I just want to know if anyone ever solve this issue, seeing that this might be the place to look for some answer from experienced user.

ps. Thx for those wiki though. They are great at getting you start. But they hardly ever solve your problems. Actually, I wish GameLift Staffs actually try all of this themselves, so they could help out people with problems using UE. They said they support UE but i doubt that they hardly ever try it themselves. So instead, I have to rely on luck for random strangers to help me out.

Sorry for complaining, but I’m very frustrate with the help here.

Okay I solved this. There was a mistake in my UE custom built, i inserted a line to prevent steam code from crashing the game.