UE4 Server SDK Plugin Setup

I am following the guide (https://docs.aws.amazon.com/gamelift/latest/developerguide/integration-engines-setup-unreal.html) to setup the UE4 Server SDK Plugin, but after I run ‘cmake -G “Visual Studio 15 2017 Win64” -DBUILD_FOR_UNREAL=1 …’, I see no files generated. The build succeeds without errors, but neither of the files are generated.

Does anyone have any idea what is going on or is anyone willing to work through this with me over Discord or Skype?

Thank you!

Hey @Fumbles

What files aren’t being generated exactly?

Because after running cmake within the “out/” directory, for example, some files must be generated with the exception of the most important ones located at “prefix/”.

In order to do that, running the following command is essential.

msbuild ALL_BUILD.vcxproj /p:Configuration=Release

Have you tried it?
It’s also important to note that you’d better run this command on x64 Native Tools Command Prompt for VS 2017 rather than any other command prompt. (Source)