Unable to connect to the local Asset Processor


I’ve got a problem when I try to launch editor.exe

here is the complete error message :

" The Asset Processor is either not running locally or not accepting connections on port 45643. Check your remote_port settings in bootstrap.cfg or view the Asset Processor log (ap_gui.log) in the log folder for any errors. "

I have already check “bootstrap.cfg” and here is a part of the content :

– ip and port of the asset processor. Only if you need to change defaults
– remote_ip=
– remote_port=45643

Everythings seems to be ok but the problem still there…

Can you please help me ?

Thank you and sorry for my bad English.

EDIT : When I launch AssetProcessor_tmp.exe in …\dev\Bin64vc140 (I use vs2015) It work perfectly but the “normal” AssetProcessor.exe do nothing …

I have the same issue after updating to 1.8 however all seems to work even when the message pop up.just few times I had some problems with it(thigs that didn’t get processed at all) that goes fixed after asset processor restart.

Hi @nOblaYa, I’ve filed a ticket to get someone to help with this issue.

Hi @nOblaYa! Would you mind posting your Asset Processor GUI log please? That’ll help us hone in on the issue. Thanks!

For some Reason, closing the asset processor and restarting lumberyard works for me. Kill the process from Task Manager or just closing it from the tray seems to do the trick.

Thanks for sharing @diemos! :slight_smile:

I was having the same issue, and found that the 1.8 asset processor was being blocked by Bitdefender as a possible malicious file. Clicked on “Allow and monitor”, enabled a couple network dialogs, and now it works fine…

No problem with 1.6… Issue only started with 1.8.

Hope it helps!

sorry to bump such an old post but i had this same problem and fixed it so i thought id add my solution. it would seem my computer is blocking the port but i was an able to find out what program was blocking it. so what i did was opened the bootstrap.cfg in the /dev directory located – remote_port=45643 and removed the “–” to un comment it and changed the port to 45642. opened Project Configurator changed to an other project and back to the project that i was having problems with. switching seems to reload bootstrap.cfg

1 Like