Unable to create new LY project

Every time I try and build/compile a new project, either in the cmd or the project configurator, the error log ends randomly at some point with:

‘fatal error C1069: cannot read compiler command line’

here is an example:

c:\Users%user%\Desktop\AmazonLumberyard\1.27.0.0\dev\BinTemp\win_x64_vs2019_profile\Gems\EMotionFX\Code\EMotionFX\Tools\EMotionStudio\Plugins\StandardPlugins\Source\MotionSetsWindow\MotionSetManagementWindow.cpp.5936967.obj’
Output:
MotionSetManagementWindow.cpp
c:\Users%user%\Desktop\AmazonLumberyard\1.27.0.0\dev\Gems\EMotionFX\Code\EMotionFX\Tools\EMotionStudio\Plugins\StandardPlugins\Source\MotionSetsWindow\MotionSetManagementWindow.cpp(1087): fatal error C1069: cannot read compiler command line
<++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++>

can somebody help me fix this, please?

This might be a pathing issue. Does the same error occur if you move your engine’s dev folder from c:\Users%user%\Desktop…dev\ to something like c:\prj\1_27\dev?

I also had LY 1.26 in C:/users/%user%/documents last time and the same problem occurred :frowning:
Or should I reinstall LY in C:/Amazon/Lumberyard like it wants me to?

ok I tried rebuilding again in the project configurator and I got this error after 7 hours when it was almost done: https://pastebin.com/WF1KE8V1

Are you replacing your username with %user% ? If not, then it’s erroring out because that’s not the right username.

I would move everything to a root location like @Gene advised.

yes, I replace the username with %user%
So I will have to move LY to something like C:/somerootfolder?

1. LINK : fatal error LNK1109: cannot remove file 'C:\Users\%user%\AppData\Local\Temp\lnk{474D67E5-9282-4002-B20A-37C0CEE45FB5}.tmp'

I have heard of some instances where the compilation is blocked by virus protection, this might be the case here…

I was wondering about that :slight_smile:. Well anyway, I am re-installing LY in C:/Amazon/Lumberyard. So, when I’m done I will try removing antivirus when building :slight_smile:.

1 Like

I guess it is working, but every time I try to compile, It now says out of memory.
my specs are core i7 6500u 8GB ram around 50GB free disk space and intel HD graphics 520. Maybe I should untick the ‘Compile Lumberyard editor and tools’…

@APerson You’ll need the ‘Compile editor and tools’ option. The free disk space is likely the issue right now, you may need close 100GB. If you feel you should have more free space on your disk, the cache folder from a previous compile attempt can be deleted. If you are pressed for space another option is to skip creating your own project and just create new level in one of the existing projects like StarterGame.

You need to crank up your pagefile size. At only 8 gigs the linker will max out and give up.

Ok, I got it WORKING! :slight_smile:
what I did

  1. install LY in C:Amazon/Lumberyard
  2. Disable folder from being scanned by my antivirus and made sure folder is not read-only (I don’t know if this was the reason it worked or not though)
  3. run setup assistant & tick the first 5 options and then I ticked 4 options later (It worked when I did this)
  4. Build the project. Takes way less time now.
  5. I can open my project

Thanks for the help everyone! :slight_smile:

1 Like