Unity Android IL2CPP System.Configuration NotSupportedException

Hi, My game client makes NotSupportedException with android build

Work perfect on PC version and even work perfect in Editor-anroid. (Also no problem with MONO)
problem only occurs in android build - IL2CPP but must use it because of 64bit.

here is logcat

It’s Unity’s IL2CPP Problem but is there any way to solve this problem?

Any help will appreciate. Thanks!

1 Like

Hello, I have the exact same error in the logcat when I try to build in il2cpp using an amazon plugin. Everything works fine in mono but not in il2cpp. Did you manage to fix it?

Same problem here but for iOS.

Has anyone got an IL2CPP iOS build working? Ours freezes when it tries to connect to GameLift.

1 Like

I’m also having this issue. I can build my game to mac or run in the editor fine, but building for iOS via xcode leads to the [System.Configuration NotSupportedException] error when I run the game on my device, causing all of the AWS gamelift object instantiations to have null references.

I have turned off code stripping and also have a link.xml with all of the AWS tools I’m using, so I don’t think it’s that.

1 Like

I got this working (on iOS) by switching to AWS 2.0 SDKs from the zip in this documentation page: https://aws.amazon.com/blogs/developer/referencing-the-aws-sdk-for-net-standard-2-0-from-unity-xamarin-or-uwp/

I had to make some code changes (have to use async functions for many network calls, but that should be moved to lambda once I’m done with my proof of concept anyways).

I used the libraries from the realtime package as they were, I think. After this it would build.

Unfortunately, now I am running into issues with TLS not working on ios builds, but as far as this specific error it’s resolved for me :slight_smile:

I have built to android using IL2CPP without any problem and launched on Google playstore. This is not an IL2CPP problem but an Amazon one.