Unreal Engine Server Build Error

Hey guys thanks for taking time to answer this question

So after adding Git and Cmake into PATH, command prompt runs and builds, but I get this error:

For those of you wondering what commands im using to build, im using the following on command prompt:

cmake -DBUILD_FOR_UNREAL=1 -G “Visual Studio 15 2017 Win64”

msbuild ALL_BUILD.vcxproj /p:Configuration=Release

Also, my SDK file is in base C:\ Directory (C:\GameLiftServerSDK…)

For those of you that might say, “Hey just add Git to PATH!”

This is my PATH:

C:\Program Files\CMake\bin; C:\Program Files\Git\bin;

on both local user and all users. So i don’t think it’s a Git issue?(I might be wrong)

EDIT:

I fixed one of the two errors by getting rid of spacing between my PATH directories.

Turns out you cant have spaces on PATH directory, only semicolons.

The error logs are attached below:

Thank you for your help :slight_smile:

Hello @wingd

I think you might be running into a similar issue that was described here: https://forums.awsgametech.com/t/build-error-when-setting-up-the-unreal-engine-server-sdk-plugin/2811/1

tl;dr;

  • Try running cmake and msbuild from a clean directory
    Hope this helps!

Alexis

Ah! I read your original post too quickly.

cmake -G “Visual Studio 15 2017 Win64” is not officially supported in this 3.1.5 release.
We support these cmake generators:

  • Visual Studio 14 2015 Win64
  • Visual Studio 12 2013 Win64
  • Visual Studio 11 2012 Win64
    So, in your case, I believe “Visual Studio 14 2015” would be best.

Alexis

So i tried running on a new build and fixed the spacing issue with my PATH.
Now GIT runs, and i only have 1 more error.

Could you help me with this one?

I’m not sure what the error is…

Thank you so much!! :))

Hi @wingd

Did you regenerate ALL_BUILD.vcxproj by running: cmake -G “Visual Studio 14 2015 Win64" ?

I should have been more clear earlier. What we need to do here is to change the cmake generator used to create the Visual Studio solution and projects files. By running cmake -G “Visual Studio 14 2015 Win64", you will create a set of files that will allow msbuild to build the code using msvc14.

Just want to make sure I understand the issue properly.

From the root directory of the GameLift Server SDK:

  • mkdir outVS2015
  • cd outVS2015
  • cmake -G “Visual Studio 14 2015 Win64" … -DBUILD_FOR_UNREAL=1
  • msbuild ALL_BUILD.vcxproj /p:Configuration=Release
    I hope this gets you unblocked!

Alexis

I uninstalled Visual Studio 15 completely and installed Visual Studio 14.

However I still get the same error…

Thank you for your quick response Alexis.

Here is the screen after cmake -G “Visual Studio 14 2015 Win64” -DBUILD_FOR_UNREAL=1

(It wouldn’t let me run cmake with this synxtax:

Here is the screen after

It doesn’t seem have to changed anything

Hello,

I honestly cannot reproduce this issue at this time.

What is the output for these?

  1. git --version
  2. cmake --version
  3. msbuild /version
    Again, sorry you’re running into these issues.

4649-5.png

Thank YOU for being patient with me on this problem.

More details in case you’re curious:
Windows 7 Ultimate x64

AMD FX 8350 CPU

Visual Studio Installed on C: Drive

Unreal Engine Folder is on D: Drive

Hi @wingd, Can you scroll up to where the error in red first occurs and post a screenshot? That may help us find the context of the error.

Thanks,

Ben

@Primer I’ve solved the problem, and posted the solution above.

Thanks Ben and Alexis :slight_smile:

Found out the solution guys, for anyone else who is getting this same error
“MSB6006 ERROR”

This image shows the solution:

Ah, great find!

So, the solution is simply to install the VS C++ core features?
Sorry this took so long to figure out. Glad you’re unblocked.