Updated And having problems with Importing animations

@Ajia Please please help me. I cannot do fps animations. It worked one time. But I am unable to reproduce what I did. I followed the docs and videos but It always gives me the same result. Twisted animations. I have imported the same fbx into Unity and Unreal and it is fine. I’m not certain but there may be some root bone scaling when importing into lumberyard, because I have tested it in blender to see what would cause it and it seems similar to what is in lumberyard. But Idk @Ajia Please help me find a solution and walk me threw the steps. Because right now I am unable to go any further in my game because this has cause me Headache.

New link to new FBX and Blend File.

Look This is what Happens or similar:

Hey @steveH,

It looks like you still have some similar problems to last time. I’m not familiar with blender so I can’t provide guidance using blender, but it’s the same rules we tried last time:

  • The proper root joint (which you have named RootBone) is currently parented under another transform node called Root (which is not the proper skeleton root). The real root joint of the skeleton should not be under anything.
  • There
    shouldn’t be any scale other than 1 for your Root Joint (named RootBone) and your Skinned Mesh. The transform node named Root is set to 100 scale, which is also impacting the RootBone. This should be fixed when you correct your root joint and skeleton.

If you are looking at the hierarchy in blender to see what is Parented it is not accurate for parenting. The Thing that I called Root was the name of the armature. The bone that is the root Bone is the Highest in the hierarchy of bones. And there is nothing higher. I made a video to show you More in detail Hope it helps. Link:

https://www.youtube.com/watch?v=sknQ-xlNmw4

I also Imported the same animations into Unity and Cryengine and everything was fine.

Here is a pick of the animation playing in cryengine.

There is Scaling when it is imported into lumberyard. I found the button that shows you the armature in the Emotions Fx Editor. Look.

That blue line is the armature.

I zoomed in so you can c it.

Hey @steveH,

Did you fix the scaling on your skinned mesh? It was also set to 100 and it should be set to 1.

Hey @steveH,

I was able to get some assistance from someone a bit more familiar with Blender. So it turns out within Blender, you can change your Scene Units. Keeping the Blender defaults may be resulting in some oddities when trying to bring the FBX in to Lumberyard, so we are recommending that you change the settings to Centimeters.

After changing this, you may want to adjust your grid display as well.

The Unit Scale Property should be set to 0.01 when Centimeters is set as your Units (it may come in super tiny but the skin should match the skeleton size after this adjustment).

Just ran another test (after watching how the Blender person did the setup), you do need to set Unit Scale to .01 with Centimeters, otherwise it still comes in incorrectly.

Glad that worked, @steveH :slight_smile:

The only side note I would add is since your asset is coming in so tiny, you would either want to fix it in Blender so it is the correct size in relation to the world. Or as a hacky alternative, you could set the Scale in the FBX Settings in Lumberyard for both the Actor and Motion to 100 to compensate.

I would recommend fixing it in your source file (Blender) though so everything is just 1-to-1 when you bring it into Lumberyard.

@Ajia The mesh scale is 1. And I applied Rotations and Scales.

Ok I’ll try it ty so much for your help.

Its Working :smiley: tytytytytytyt.

Ok :smiley: will try that too.

Hey @steveH,

One more update for you. After some additional tinkering, it seems like instead of adjusting your Scene Units to Centimeters, you may be able to just change it through the type of FBX Export settings and changing the default to “FBX Units Scale” instead and keep your asset at Meters or Blender Default Units. Blender defaults to Meters, and FBX seems to default to Centimeters, so just forcing the FBX standard upon exporting the FBX asset from Blender looks like it resolves the confusion for Lumberyard. The asset appeared to come in at the correct size too when doing this, but you may need to do some additional testing to confirm since we only had the one asset to test with.

7358-blender-fbxexport-fbxunitsscale.jpg