Vibrating Scenes

I’ve opened the start-sectionxyz sample scenes and each one is vibrating in the main view. They’re displaying at 1322 x 806 in the main view on a 4K monitor at FPS 174.5 - 5.8ms. I’m running an i7X processor with 1080 Ti SLI. The vibration is so bad its unusable. Has anyone else experienced this? Is there a setting I can adjust?

Thank ya much! Let me see what I can dig up for this topic :slight_smile:

I’m using the original 1.10 that was posted for download.

Hey @blacksitelab - which version of Lumberyard are you using?

I just pulled up Lumberyard again (after a computer reboot from last night) - now there’s some vibration on the icons but the scene itself is not vibrating. I’m not sure what could have caused the original vibration, I’ve made no changes other than a restart since last night.

Sure, I just recorded a few seconds of the vibration.

https://youtu.be/Oo8oyqAmtUY

The vibration you see on the helper elements was happening with the entire scene, luckily it hasn’t happened since the original post. If you zoom into the scene, all the helper elements are vibrating (not just the ones on the physics wall). If you turn off the helper elements, the physics wall itself is vibrating unless you zoom in very close.

Good afternoon!
I am one of the Technical Artists on the Lumberyard team. Do you think you could capture this behavior with snagit or fraps and attach the video to this thread? That would help me greatly in helping you solve this issue!

-MajorBliss

Thank you! I see what you are talking about. The helper icons could be just z fighting with geometry, as is evident by the one in the sidewalk. However, I am a little curious about the comment you made in regards to the physics wall vibrating. Could I ask one more favor, could you zip up your level and attach it here so I could take a look at your exact set up?

Here are my thoughts,

  1. It is a graphics card issue (driver related)

  2. The stacked physics objects could be intersecting slightly?

However, I would want to confirm those first theories by looking at your exact set up.

Can’t wait to get eyes on it for you, thanks for bearing with me while I help you look in to this!

-MajorBliss

Thank you for the information. Let me dig a little bit and I will ping this thread again when I know more!

Hi MajorBliss:

  1. Ok, I actually rebuilt my machine from the ground up, reinstalling Win 10 Pro and updating all drivers with Driver Easy. So I am using the latest Nvidia driver for my 1080 Ti cards.

AFTER rebuilding and reinstalling, now the entire scene is vibrating again. I rebooted and tried again, but no go - the entire scene is still vibrating.

  1. I would actually have no idea, I’m opening the Lumberyard built sample scenes for the tutorials.

Ok, I am seeing what you are seeing now! I’m sorry this is happening, that is definitely distracting. I have detailed information below:

  • This is due to our new AntiAliasing solution “TAA”. It is trying to resolve the depth between our helper icons and the objects in the world (it also happens with wireframe selections). I have submitted a bug to our product team to find a solution for editing in LY, in the mean time, though, let me give you some steps to hide this issue, so you can work and make awesome stuff!

Two Methods:

  1. You can just turn helper icons off (click the little “?” symbol in the top right of the viewport):

  1. OR, you can disable the “TAA”.
  • Open Console

5335-2017-08-29-11-49-39.jpg

  • Click on the “Console Variable” icon:

  • In the search box type “AntiAliasing”

  • Change the AA mode to “2”, and BOOM, jitter gone.

I hope this helps, apologies for the trouble!

Have fun creating!

  • MajorBliss

Thank you for the heads up. I knew about deactivating the helper icons, that only worked when it was only the helper icons vibrating. When the full scene is vibrating, turning off the helper icons doesn’t help (no pun intended), the only option to stop the vibration is changing r_AntialiasingMode to 1, which makes the scene look terrible :frowning:

Mode 2 should work and looks a lot better than 1. Also if you hit Ctrl + G and go in to game mode do you still see it or only in edit mode?

Good morning!

I wanted to update you on the progress, in regards to this issue. We have identified some areas of improvement with TAA and are working on an iteration that is targeted for a future release. Thank you for bringing this issue to our attention!

-MajorBliss

It’s been nine months now and I’m back experimenting with Lumberyard again. I’m really excited about the progress and all the new tutorials and am anxious to dig in, but this vibration issue persists in the default setup. Setting the r_AntialiasingMode to 2 does fix the problem now.

I hope this feedback does help the devs and others who might experience this issue.

Hey @blacksitelab,

Thanks for testing it again in a more recent build. Glad to hear that setting the cvar to 2 is resolving it for you! And I agree that hopefully other users will find it useful if they happen to see the same problem. :slight_smile: