Video playback gem can't add video/ Video playback is delayed

I was able to install the gem and run the editor without errors. However, I am unable to add the video snippet to the line. I practiced several formats and none came up. How to fix this and what’s the matter?

Is there any error message in the console window?

no, no errors and nothing at all happens in the console

I tried and got same result, the pick window just closes, but Video field stays empty.
However, tried with script canvas, and it worked with video playing on the entity as expected:

Set this script to same entity that has the video playback component.

Don’t forget to setup material as described here:
Video Playback - Lumberyard User Guide (


Hello everyone! And I have a rather difficult question. I am using video playback in ui with a duration of 41 seconds. And everything works well, but the video starts playing exactly after this time. How to fix this? The fact is that this video should be launched at the very beginning of the game, and not after 41 seconds. There are no delays in the script canvas. And also the component with the video is active immediately. But playback starts only after 41 seconds, as if it was playing in the background, but it becomes active only after invisible playback
Please help me figure it out, this problem I have been sitting on for a very long time! :fearful:

you said it has a duration of 41 seconds, after 41 seconds it becomes visible? From what I am reading it seams the duration is just until it is visible so if you want it on immediately set it to like 0.1 seconds or something like that.