Viewport entity icons misaligned with a 4K monitor

When using a 4K monitor (and maybe any high DPI display), the entity icons in the viewport are completely misaligned, and cannot be selected. The only way for me to select objects is in the entity outliner. I’m not even using a fullscreen viewport, just the standard size in the default layout. Any way to fix this? Makes the whole level design workflow very annoying to work with.

Anyone? I’m currently forced to select objects via the entity outliner.

Apologies for the delayed response @WhatsThatFunction — does this still occur in the latest version of LY?

Yes, I’ve tried both 1.12 and 1.13 and still have this problem.

@WhatsThatFunction , I had the same problem. Going to Window’s Display Settings->Display->“Scale and layout” and setting it to 100% seem to have resolved it. The icons are quite small, but correctly aligned and selectable. Maybe Lumberyard’s UI can be improved to handle Windows scaling a bit better.