Visual studio 2017 compile problems

@Amonster_LMBR @BigMonet

Console compile

lmbr_waf configure , not working , no idea why as I told setup to use my 2017 install , not able to find it :

INFO] Using Visual Studio version 15 installed at: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community
[WARN] VSWhere could not find an installed version of Visual Studio matching the version requirements provided (-version [15.7.27703.2035,15.9.28307.665]). Attempting to fall back on any available installed version.
[WARN] Lumberyard defaults the version range to the maximum version tested against before each release. You can modify the version range in the WAF user_settings’ option win_vs2017_vswhere_args under [Windows Options].
[WARN] Unable to initialize platform (Unable to find Visual Studio 2017 (-version [15.7.27703.2035,15.9.28307.665]) C++ compiler and/or Windows Kit : msvc: Could not find a valid Visual Studio installation for building.). Disabling platform.

THis too:

[WAF] ‘Configure Projects’ successful (28.866s)
[WAF] ‘configure’ finished successfully (33.041s)
[WAF] Executing ‘msvs’ in ‘e:\Amazon\Lumberyard\1.19.0.0\dev\BinTemp’
[INFO] Regenerating 3rd Party settings file…
Unable to generate solution for ‘Visual Studio 2017’. Make sure it is installed and enabled in Setup Assistant. Skipping visual studio solution generation
[WAF] ‘msvs’ finished successfully (4.039s)
[WAF] Executing ‘generate_uber_files’ in ‘e:\Amazon\Lumberyard\1.19.0.0\dev\BinTemp’
[WAF] ‘generate_uber_files’ finished successfully (57.474s) , indicating something was successful, but clearly couldn’t find VS2017 so saying ‘successful’ is dubious ?

HOw to fix ? :wink:

thx

1 Like

Hi @cajunctionAI,

The most likely reason is due to the Visual Studio version you have installed being newer than any version we tested with Lumberyard. Posted here as well for reference: https://forums.awsgametech.com/t/unable-to-generate-solution-for-visual-studio-2017/6840/1#answer-77022

To resolve this issue we need to modify your build settings file

  1. Open a command prompt and navigate to your Lumberyard dev folder
  2. Run the command to generate a build settings file if you don’t already have one
    lmbr_waf configure
  3. Open dev/WAF/user_settings.options with your favorite text editor
  4. Find the following line which specifies the valid versions of visual studio 2017
    ;win_vs2017_vswhere_args = -version [15.7.27703.2035,15.9.28307.665]
    Change it to this which allows all of 'em. NOTE: make sure to remove the semi colon at the beginning of the line
    win_vs2017_vswhere_args = -version [15.7.27703.2035,16]
  5. Back in your command window run
    lmbr_waf configure
    After this, your version of Visual Studio should be properly detected.
1 Like

Hi and thx for assistance, = I altered file as asked,but still getting this:

[WAF] Configure “win_x64_vs2017 - [profile,performance_dedicated,profile_test_dedicated,debug_dedicated,debug_test_dedicated,release,release_dedicated,debug_test,debug,performance,profile_dedicated,profile_test]”
[INFO] Using Visual Studio version 15 installed at: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community
[WARN] Unable to initialize platform (Unable to find Visual Studio 2017 (-version [15.7.27703.2035,16]) C++ compiler and/or Windows Kit : msvc: Could not find a valid Visual Studio installation for building.). Disabling platform.

How do I resolve this ?

Thx

Your missing required VS Items (a SDK, and the compiler)

The Visual Studio 2017 default installation may not include all of the required features to run Lumberyard. Ensure these features are selected during installation.

To verify your current installation of Visual Studio 2017

From Windows, click Control Panel, Programs and Features, Microsoft Visual Studio version_number.
OR    
Search *Visual Studio Installer*

Select Modify.

On the Workloads tab, do the following:

    Select Universal Windows Platform Development and select the following:

        C++ Universal Windows Platform tools

        Graphics debugger and GPU profiler for DirectX

    Select Desktop development with C++ and select the following:

        Visual C++ ATL for x86 and x64*

        Visual C++ MFC for x86 and x64*

    Note

    *You can run Lumberyard Editor without Visual C++ ATL and MFC libraries. However, to build Lumberyard Editor, you must install these libraries.

    Select Game development with C++ and select the following:

        Windows 8.1 SDK and UCRT SDK

On the Individual components tab, under Compilers, build tools, and runtime:

    You must select at least one version of the VC++ 2017 toolset.

Make sure all that is installed
make sure you have all that, as that is usually the number one cause
and choose to use 2017 instead of 2015

1 Like

I’lll check, but I DO have 2017 already selected.I’ll let you know, and TY so much, when fixed;)
cheers

H i

Any reason I need Windows 8.1 SDK and UCRT SDK ? I have win 10 pro, or is that simply one of the current LY requires,if so good.

All else is fine, just verifing as I’m trying to save hdd space.
Id use my ssd but no room atm.

TY

an OS is not the same as a SDK.

The info i put tells how to get an SDK

Not what I meant, do I NEED the 8.1 sdk given I have windows 10 ?