Visual Studio requirements and compatibilities

I have seen conflicting information on what is required and what is supported by Lumberyard with respect to Visual Studio. My experience also conflicts with what has been posted by Amazon staff.

The “required” version is posted/documented to be “Visual Studio 2013 Update 3 or higher,” which is how it is displayed in the Lumberyard Launcher when configuring the engine from scratch. When I first set up version 1.0, the launcher kept showing that it was “Not found” when I installed Community 2015 with Update 1, then uninstalled and installed Community 2013 with Update 5, and only changed to “Found” when I then uninstalled Community 2013 and installed Professional 2013 with Update 5. This worked fine for Lumberyard, but I don’t have a license for Pro 2013 and can’t afford one, so I couldn’t use it directly for anything after the 30 day trial ran out.

Both old and recent posts by Amazon staff state that Lumberyard should work with both Professional and Community editions, which is not supported by my experience above. So is this fixed with Lumberyard 1.1 or do I have to modify the file Lumberyard\1.1.0.0\dev_WAF_\default_settings.json (used to be the user_settings.options file) as described by @Anorak at https://forums.awsgametech.com/t/multibytecs-mfc-with-visual-studio-2015/304/1? If I want to use the free Community edition of 2015 do I also have to install Professional or Community 2013, then update the options file? The 1.1 Release Notes (page 16) says that the “Lumberyard Launcher might fail to run if msvcr120.dll is not present. You can resolve this issue by installing the Visual C++ Redistributable Packages for Visual Studio 2013,” so is this all that is truly required in terms of VS2013?

I would try all of these combinations myself, but I don’t really have the time and don’t want to mess up my development environment.

I decided to install Lumberyard on a couple of different computers so that I can gain more familiarity with it from more than one location. So I tried installing Visual Studio Community 2013 with Update 5 and the Lumberyard Launcher was able to find it after a refresh. I also tried

Visual Studio Community 2015 with Update 1 on one computer and modified the default_settings.json file to look for VS version 14, but the launcher would not continue until I installed Visual Studio Community 2013 with Update 5 as well.

The Lumberyard Launcher will see:

  1. Visual Studio Community 2013 with Update 5 - Yes
  2. Visual Studio Professional 2013 with Update 5 - Yes
  3. Visual Studio Community 2015 with Update 1 and updated settings file - No
  4. Visual Studio Pro/Ultimate/Other 2015 - Unknown, but probably No
    So unless you really prefer version 2015 over 2013 (or already have a licensed copy of 2015 and don’t mind also installing 2013), just use version 2013 by itself.