WAF Error problem I tried plenty of stuff it doesn't work please help

Hi can you please help me solve this waf error problem, I’m frusturated at this point and would like to ask a few questions as well. When I hit rebuild project I’m getting WAF error. I checked every solution on this topic in forums. I got VS 2019 and has that MPS or something package I can’t remmember it’s name but I got that, I tried changing code in WAF settings according to a post I read here, didn’t worked, I uninstalled Lumberyard and reinstalled it and it just insists on not working.

Unreal Engine 5 for instance, also in Early Access, you hit download, you hit install and boom, it just works.

I like Lumberyard, I like it’s UI, it’s entity system, excellent renders but why install process has to be so counter-intuitive? If people are currently working on Lumberyard, they should work on improving initial installment before adding new features. I have not seen a worse installment process than Lumberyard, might as well building it myself from the source code seems like it would have been easier. This is ridiculous.

Also what the hell WAF stands for anyway?

I was going to upload screenshot but apparently “new users cannot upload files”

So here’s a drive link that includes log txt aswell. Only thing missing in “Install Software” section is Speedtree.

It just doesn’t work I tried a lot of stuff please help

Edit: Also I use VS2019 do I need VS2017 ???

Edit 2: Lumberyard is not installed on C instead it’s intalled in ssd drive S should I move it to C ?

Edit 3: Lumberyard Setup Assistant has a green check on everything required so why the hell this thing is not working?!?! :smiley:

Edit 4:

[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5core.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5core.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5core.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5gui.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5gui.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5gui.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5network.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5network.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5network.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5qml.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qml.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qml.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5quick.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5quick.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5quick.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5svg.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5svg.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5svg.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5widgets.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5widgets.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5widgets.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5qmlmodels.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qmlmodels.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qmlmodels.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5qmlworkerscript.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qmlworkerscript.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5qmlworkerscript.dll’
[WARN] Unable to copy s:\lumberyard\shared\3rdparty\qt\5.15.1.1-az\msvc2019_64\bin\qt5xml.dll to c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5xml.dll: [Errno 13] Permission denied: ‘c:\lumberyard\1.28.0.0\dev\bin64vc142\qt5xml.dll’

It says “Check the file permissions or any process that may be locking it.” I did checked the file permissions, it is not read only, users have full access and I’m running Project Configurator admin mode.

Edit 5: About Error no 13 Permission denied error in another post someone says restart fixes it so I restarted the PC and it’s not solved. Lumberyard hates me :smiley: I have tried so much stuff it just does’t work.

Edit 6: I revert folder properties of lumberyard, I uncheck “read only” but when I try to rebuild project it automaticall reverts back to read only and gives error.

Edit 7: At this point, I don’t know what else to do. I installed this QT software thinking maybe it would solve it. It didn’t, why permission is denied? Who knows! I guess I have to prepare the perfect condition for it to run with scientific precision like as if I’m trying to discover higgs boson. Do I need a hadron collider to run this thing?

It is for managing directory and compiling. I think they will move to CMake now not WAF. If you just upgraded recently. Better have fresh download of everything. Erase all recent files and uninstall. restart. then a fresh download of everything will work. This engine looks easier to use than any other game engine. It looks smoother and light also. But this process before you can use it is a bit problematic. It is in beta for too long. They should release a separate one that is not modular but with all stable features.

1 Like

Ralph is right, within a version or two C Make will be out which gets us out of all waf related building. I assume you do not want to wait until that is out, so my biggest advice is use vs2017. A lot of people had issues with 2019, you need a certain version of 2019, not the newest. And for 2017 everything seems to just have a lot less bugs with it. But for ralph, if they made a seperate release that is not modular with all the gems built in each project would be massive, and nothing would be usable for mobile creators. Also a lot of gems are used for AWS Services, and a lot of people do not use half of them, but it just adds gb to your game if the projects were created with everything built in, that is most likely why that has not became a thing, also the beta thing is because the engine is changing too much to ever be in a full release. A new renderer, math, C-Make, and much more is all coming in the next few versions of lumberyard. Just trying to clear up a few things here.

Thanks for the reply, alright I’ll install vs2017, and then have a new Lumberyard install and see if it works.

1 Like

Once again thank you! Hadron collider is working now, I have finnaly discovered higgs boson :smiley:

1 Like

Yes that problem is solved, unfortunately now I’m facing yet another error and there is no log file this time either. When I launch the editor, it says, “Engine, Game or Editor Crash” “Lumberyard has encountered an error and needs to close”

I once again googled it and there was posts about high dpi problems for previous versions so I changed that to compability mode but it didn’t worked. I changed screen resolution didn’t worked either.

Edit: I made sure asset procceccor from previous launch was closed and did not worked either. And windows language is english.

It says Refreshing the asset catalogue for a while and then gives the error.

The first thing you can try is delete the Cache folder under the dev folder on your project, do not worry it just takes a little to relaunch the project nothing gets deleted that will not recompile. If that does not work I would say if you have a level open when you start up your project sometimes a level could get corrupted, and to check this just delete the level from the levels folder in you project folder, or move it out of the levels folder, and if it opens up fine, and you try and jump back to the level and it crashes that is a corrupted level, which is usually pretty difficult to fix, I usually if this happens just go to a backup I made and copy the level and paste it in the level folder in my project.

They can release a separate stable or almost stable version (with no dependencies). And make gems, sdks, sample projects just downloadable. gems are just plugins. sdks are just for people who knows programming and needs certain output of their project. Sample Projects are just for reference. At least with this approach people can use the engine with just around 10gb downloads or maybe less. Rather than downloading all the crap that you wont use. Saving other people from mess of compiling. It is still modular in a sense that the user needs to download specific thing he wants.

I fully agree with you with the starter project. That does have a lot of extra gb that are not needed for expierenced users. But say they did exactly what you are saying. You would be able to download the engine on its own with no sdks that are not needed for any of the gems, so this now comes down to what gems you plan on using, because say you want to use gamelift and if they make it so you no longer have to build the gems you would just add gamelift to your project after downloading the prebuilt gem from their server. Now you issue comes in without the correct sdks gamelift will not work. So the reason of the large file size only comes in because a lot of the dependencies you download are used for gems that may need them. If you do not need those gems though, I do see what you are talking about of the unnecessary size, but to fix this a lot of work would need to be done each release just to get the small file size usable for the public without all the sdks. I think after C-Make comes out, the file size is going to shrink a little because waf is a little bigger, and also way less time and waf errors will no longer occur. I like how you are thinking though, and would not complain if it becomes a thing, there is just a lot that would have to be rewritten for this to be a reality.

Btw problem is continuing, I’m trying lots of different stuff, but it just doesn’t work.

Bin142 doesn’t work at all I suppose it’s for that specific version of VS2019, it gives gem errors and no matter what I do Bin64vc141 says “Refreshing Asset Catalogue” and then gives that error. I mean error after error, in almost every single part of installment process I’ve encountered a rich assortment of errors, an open buffet of errors. Great work Lumberyard devs! Pick the error you like, there are so many of them, they come in so many variety. It’s like a Christmas feast comprised of errors. Dark Souls boss designers are not as creative at coming up with challenge variety as Lumberyard at producing error variety.