Watervolume reflections

Hello,

I’m trying to create a lake, but I can’t add any kind of reflection to it leaving me with a almost black, moving blob. Under the “Texture maps” category for the watervolume shader there is no place for an environment map. Has this been removed? If yes how do I get reflections at all? It won’t allow me to check “Realtime reflections” under “Shader generation parameters” either so I’m stuck.

Any help?

Thanks.

@Ihatenames

Can you please tell me what version of Lumberyard that you are using? Have you added any EnvironmentProbes?

Thanks. I’m using version 1.8.0.0. I did add an EnvironmentProbe and when using a sphere with glossiness near 100% it does show the cubemap on it. Maybe I missed some changes to the watervolume shader? My brain says that there was an environment map slot in the shader and that you had to put a cubemap in there in order to be able to check “Realtime reflections” in the shader generation parameters.

@Ihatenames

I just want to be certain that it is working for you. When using the Watervolume shader, there is a Texture Map parameter called Environment. This should point to the EnvironmentProbe that you want the reflections from.

Here is a screenshot of my setup:

I hope this helps clear up any confusion. Let me know!

Exactly. Problem is I don’t have that slot :slight_smile:

Does this require a certain gem? I’m on a custom project but I didn’t modify source code other than adding a custom component, which is not even used yet. The problem also appears inside the SamplesProject. I’ll try recompiling, maybe that helps.

EDIT:

Unfortunately rebuilding everything didn’t help either.

Soo I got a new connection today and figured reinstalling might solve the problem, but it didn’t. I am still missing that “Environment” slot in the material. Any new on this? I’m using version 1.8.0.1

Workaround thanks to EricRLA

EricRLA * ·
15 hours ago

           *

@Ihatenames
I had this problem awhile ago. Try this and see if it helps. Change the
shader to Glass and in the environement texture slot type in nearest_cubemap, then change the shader back to the watervolume.

Thanks that worked.

@Ihatenames I had this problem awhile ago. Try this and see if it helps. Change the shader to Glass and in the environement texture slot type in nearest_cubemap, then change the shader back to the watervolume.

1 Like

THANK YOU!!!