What's going on?

So for some reason, I can not get Lumberyard to actually open. I’ve re-extracted already.
Maybe an extra eye on the matter will help

Here’s the log that I have from it so far:

Loading system configuration from system_windows_pc.cfg...
[Warning] Config file system_windows_pc.cfg not found!
GameDir: BeachCity
GameDLL: SamplesProject.dll
[Warning] Config file game.cfg not found!
[Warning] Cannot open Pak file %assets%\shadercachestartup.pak
[Warning] Cannot open Pak file %assets%\engine.pak
[Warning] Cannot open Pak file %assets%\engine.pak
[Warning] Cannot open Pak file %assets%\shadercache.pak
[Warning] Cannot open Pak file %assets%\shadercachestartup.pak
[Warning] Cannot open Pak file %assets%\shaders.pak
[Warning] Cannot open Pak file %assets%\shadersbin.pak
Asked to load pak 'Engine.pak' to memory, but did not find it in the list of available paks.
creating CVarGroups from directory 'Config/CVarGroups' ...
Windows 8 64 bit (build 6.2.9200)
User name: "lybuilder"
System language: English
Windows Directory: "C:\Windows"
Local time is 23:27:29 01/21/16, system running for 52885 minutes
7680MB physical memory installed, 5336MB available, 134217727MB virtual memory installed, 30 percent of memory in use
PageFile usage: 20MB, Working Set: 15MB, Peak PageFile usage: 20MB,
Current display mode is 1024x768x32, (Unknown graphics card)
IBM enhanced (101/102-key) keyboard and no mouse installed
--------------------------------------------------------------------------------
[Warning] Config file system_windows_pc.cfg not found!
[Warning] Config file user.cfg not found!
Stream Engine Initialization
GameName: Lumberyard
BuildTime: Jan 21 2016 23:04:51
<Audio>: Running with NULL AudioSystem.
Time initialization
Initializing Animation System
Script System Initialization
Initializing additional systems
Dynamic Response System initialization
No Dynamic Response System was loaded from a module, will use the NULL DynamicResponseSystem.
[Warning] XML reader: Can't open file (Config/PerfHud_PC.xml)
failed to find CVar: r_wireframe
failed to find CVar: r_MeasureOverdrawScale
failed to find CVar: e_CameraFreeze
failed to find CVar: r_PostProcessEffects
failed to find CVar: r_HDRRendering
failed to find CVar: r_deferredDecalsDebug
failed to find CVar: e_Shadows
failed to find CVar: e_WaterOcean
failed to find CVar: e_Particles
failed to find CVar: e_Terrain
failed to find CVar: e_Brushes
failed to find CVar: e_Vegetation
failed to find CVar: ca_DrawChr
failed to find CVar: e_CoverageBuffer
failed to find CVar: e_Sun
failed to find CVar: r_Unlit
failed to find CVar: r_texbindmode
failed to find CVar: r_deferredShadingEnvProbes
failed to find CVar: r_texbindmode
failed to find CVar: r_texbindmode
failed to find CVar: e_defaultMaterial
failed to find CVar: e_debugDraw
failed to find CVar: e_debugDraw
failed to find CVar: e_debugDraw
failed to find CVar: r_Stats
failed to find CVar: r_ProfileShaders
failed to find CVar: sys_flash_info
failed to find CVar: r_showmt
failed to find CVar: e_streamcgfdebug
failed to find CVar: r_TexBindMode
failed to find CVar: r_TexturesStreamingDebug
failed to find CVar: r_TexturesStreamingDebug
OnSysSpecChange(0)
[Warning] Config file editor.cfg not found!
CSystem::Quit invoked from thread 2116 (main is 2116)
System:Quit

Any ideas are welcomed.

Hi @matthew

Check this link i think it’s the same issue

https://forums.awsgametech.com/t/unable-to-launch-the-custom-project/213/1

Hi @matthew,

Just following up here to see if the post @SpikeGotti shared helped with your issue? If not, please let us know and we’d be happy to help.

@ManDroid

I am having the same issue ever since downloading 1.9.0.0, except I at least get past the game.cfg error you got.

I gotta wonder if my bad luck with Lumberyard and its asset processor is just due to installing on E: instead of C:

<20:21:12> OnSysSpecChange(4)
<20:21:12> Can't find cvar 'sys_spec_Full' value '4' group ''
<20:21:12> Loading Config file VeryHighSpec.cfg (@assets@\config\veryhighspec.cfg)
<20:21:12> Loading Config file system_windows_pc.cfg (@root@\system_windows_pc.cfg)
<20:21:12> Loading system configuration from system_windows_pc.cfg...
<20:21:12> GameDir: SamplesProject
<20:21:12> GameDLL: SamplesProject.dll
<20:21:12> [Warning] Cannot open Pak file @assets@\shadercachestartup.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\engine.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\engine.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\shadercache.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\shadercachestartup.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\shaders.pak
<20:21:12> [Warning] Cannot open Pak file @assets@\shadersbin.pak
<20:21:12> Asked to load pak 'Engine.pak' to memory, but did not find it in the list of available paks.
<20:21:12> Loading Config file game.cfg (@assets@\game.cfg)
<20:21:12> creating CVarGroups from directory 'Config/CVarGroups' ...
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_full.cfg (@assets@\config\cvargroups\sys_spec_full.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_gameeffects.cfg (@assets@\config\cvargroups\sys_spec_gameeffects.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_light.cfg (@assets@\config\cvargroups\sys_spec_light.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_objectdetail.cfg (@assets@\config\cvargroups\sys_spec_objectdetail.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_particles.cfg (@assets@\config\cvargroups\sys_spec_particles.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_physics.cfg (@assets@\config\cvargroups\sys_spec_physics.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_postprocessing.cfg (@assets@\config\cvargroups\sys_spec_postprocessing.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_quality.cfg (@assets@\config\cvargroups\sys_spec_quality.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_shading.cfg (@assets@\config\cvargroups\sys_spec_shading.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_shadows.cfg (@assets@\config\cvargroups\sys_spec_shadows.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_sound.cfg (@assets@\config\cvargroups\sys_spec_sound.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_texture.cfg (@assets@\config\cvargroups\sys_spec_texture.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_textureresolution.cfg (@assets@\config\cvargroups\sys_spec_textureresolution.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_volumetriceffects.cfg (@assets@\config\cvargroups\sys_spec_volumetriceffects.cfg)
<20:21:12> Loading Config file Config/CVarGroups/sys_spec_water.cfg (@assets@\config\cvargroups\sys_spec_water.cfg)
<20:21:12> BackupNameAttachment=" Build(0) 27 Apr 17 (20 21 12)" -- used by backup system
<20:21:12> Log Started at 04/27/17 20:21:12
<20:21:12> Built on Apr 23 2017 22:15:56
<20:21:12> Running 64 bit Windows version
<20:21:12> Executable: E:\Amazon\Lumberyard\1.9.0.0\dev\Bin64vc120\rc\rc.exe
<20:21:12> FileVersion: 1.9.0.0
<20:21:12> ProductVersion: 1.9.0.0 - Build 393006
<20:21:12> Using Microsoft (tm) C++ Standard Library implementation

The editor goes to its usual splash and has a decrementing number of assets processed. Before erroring out it freezes at 39-200 assets left to be processed (varies depending on which project is default).

It does not immediately crash, ~5 seconds after freezing it will spit an error saying something like “asset manager is already in another branch … please restart the asset in a different branch”

I don’t have the logs anymore since I uninstalled as my last attempt was to put it on my already full C: drive instead of the usual E: drive I put big files. The remainder of the log file was just system specs anyways.

The asset processor processed all the assets and had a successful connection to localhost (whatever that’s for?)

Yes, i saw this suggestion in other threads. The first project I run after doing a fresh install will load fine, but after trying to switch to a different project it breaks. Trying to switch back to that first project also breaks afterward. I have tried deleting the cache folder as well as restarting my comp to ensure no processes are left running and then booting up lumberyard, same issue.

All of these issues occurred on my E: drive ever since installing 1.9.0.0. I had other issues in 1.8.0.1 but those I somehow worked my way through. These issues persisted through 3 fresh installs on my E: drive, my last attempt was on my C: drive. On the C: drive it instead gave me the error “game cannot be initialized” which is the errors I had in 1.8.0.1, which I had fixed by reinstalling, but no luck this time. I am able to see the required game files as per suggestions in other threads, and the asset processor didn’t get stuck on anything. It just didn’t want to load the engine :frowning:

As a side note, when installing Lumberyard on a drive other than C:, it seems the engine will still try to preserve the same amount of space on C:. When I installed Lumberyard on C: it was ~11gb of space. When I installed it on E:, windows detected it as ~23gb and after removing lumberyard from my computer through the windows “add or remove programs” the space on my C: drive was freed up, even though there were no Lumberyard files present. I think Lumberyard doesn’t want to be installed on anything but C:, which is unfortunate for those who use a small SSD as a boot drive.

Please let me know if you need any other details. I would really like to use the Lumberyard engine.

Hello @pykennedy,

Can you please provide us with more information regarding the issues you are running into?

  1. What happens when the Editor is launched? Does it immediately crash? Is there more output from the log file you can share with us?
  2. Is the AssetProcessor processing any assets? Is it stuck while processing assets?
  3. Have you tried making sure that the AssetProcessor from a previous version of Lumberyard was not running before launching 1.9?

Let us know,
Thanks!

getstarted.png installoptionalsdks.png installplugins.png installrequiredsdks.png installsoftware.png summary.png 4466-lmbr-waf-configure.txt (18.9 KB)lmbr-waf-configure.txt 4467-editor.txt (20 KB)editor.txt

I tried reinstalling again on my E: drive. These are the steps I have taken:

  1. Delete all Lumberyard files and remove every lumberyard registry key/value (it took a while).

  2. Re-download the installer v1.9.0.0 and installed.

  3. Choose “launch” and select customize instead of express.

  4. Configure as per the attached screenshots.

  5. Open project configurator. See that current default is “Samples Project”.

  6. Create a new project and set it to default. Asset Processor did not start.

  7. Set default project back to “Samples Project”. Asset Processor did not start. I think I left the project configurator open during the following steps:

  8. Launch the editor. The asset processor started. Since it was the first time the asset processor took longer than it usually does. The splash was showing me the thousands of assets to be loaded. It flew through them until 149 were remaining. Normally this is where 5 seconds later I would get an error to tell me that the asset processor needs to be started from a different branch. Instead, it hung at 149 for ~10 seconds, then continued to decrement slowly until it eventually finished.

  9. The editor then automatically started and I had the option to create/load levels. During this time the asset processor was still loading assets. I let the asset processor continue until all assets were processed. The asset processor later finished processing all assets successfully, and connection to localhost on some random port was successful. I leave the asset processor open.

  10. I open the “Camera_Sample” level. It loads successfully, albeit with flickering shadows. I enter game mode and click through 5/6/7 to preview the different cameras. I exit Lumberyard by hitting the X in the top right corner. I then close the asset browser by explicitly quitting via the taskbar.

  11. I configure another new project and set it to default. Asset processor did not start.

  12. I run “lmbr_waf configure” and get the attached execution dialog (with some spam omitted). It seems to have run successfully, but as you’ll see it doesn’t look like it completed generating every file ([340/452] and [118/236]).

  13. I run Lumberyard again, with project configurator still open. The Asset processor started. The splash flew through the numbers, then sat on “First time asset processing” as it died the last time as well.

  14. Asset processor is still processing, but I get the error “Game cannot be initialized, please refer to the editor log file”. I hit OK and the splash closes, but the asset processor continues until finished. The asset processor finished successfully with no errors/warnings. There is no mention of a connection in “Connections” this time.

  15. My C: drive lost 4gb of space. I cannot find any Lumberyard files other than log files in AppData.

.

Attached again are screenshots of my installation and logs. I had no logs inside AssetProcessorTemp.

So I ran “lmbr_waf build_win_x64_vs2013_profile -p all --progress” since that was another step I seemed to have missed. After running it I was able to successfully run that project. However, after I closed out of that project and the Asset Processor and tried creating a new project I got the error I mentioned originally. See attached. Note that the splash is stuck at 64 jobs remaining.

error.png asset-warnings.png

4470-log.txt (6.48 KB)log.txt 4481-rc-log.txt (3.56 KB)rc-log.txt

Hey @pykennedy, are you still having the same issue? I’ve seen a couple users who were able to resolve similar issues by uninstalling and doing a full reinstall. Have you tried that?

EDIT: I see that you have tried reinstalling. Sorry I missed that.

Unfortunately this seems to be a known issue with 1.9 where the Asset Processor locks up. A workaround that seems to work for some users is to launch the AssetProcessorBatch.exe in the Bin64vc120(140 if using VS2015) then after that is done processing the assets launch the editor.

The team here is working on fixing the issue and will provide a patch to our users once it’s ready. Apologies for the inconvenience.