when will maya 2017 be supported?

Title says it all…

Hey @Cstudios15,

We’ve been getting requests for Maya 2017 support lately, but at this time we don’t have any details to share. Hope you’ll stay tuned!

we are a few months furter now, any news on this?

Still no news to share on Maya 2017 support at this time. We will be sure to highlight that feature as soon as we can. Sorry for the inconvenience this may be causing.

I’m waiting

Any news on this? I’ve been waiting over 7+ months now. It might be 2018 or 2019 before Maya 2017 is finally being supported in Lumberyard. Can this please be “bumped up” to be a major priority in Lumberyard? 7 months have passed, and Maya 2018 will probably be released in another 4 or 5 months, and we still can’t even get Maya 2017 support in Lumberyard yet. It seems like Application Support and Tool/Plugin support is really lacking in Lumberyard. Also, any news as to when builds will be supported by Visual Studio 2017? (not just Visual Studio 2015 or 2013). Can these items please be put towards the top of the list? (or possibly hire a few extra developers that can focus solely on supporting the latest applications/tools such as Maya 2017, and Visual Studio 2017 build support in Lumberyard)

Over 7+ months later now, still any news on Maya 2017 support yet?

Hey @Cstudios15, @OdiGames, @Mitch, @Mark.Malewski,

Sorry for the delay in a response, we may have missed the announcement during all the GDC prep and actual week of GDC. Maya 2017 plugin and support was released with 1.8 (which shipped about 2 weeks ago). You can find it in the release notes. Hope that helps!

I just looked at the 1.8 release notes (under Maya 2017). Yep, it’s there! Awesome thanks @Ajia for the quick response!

maybe it’s better to make a plugin for maya 2018 now so it will be ready when they launch Maya 2018 :wink:

Well, that was over 2+ years ago… now what about Maya 2018, and 3ds Max 2018 support getting added to Lumberyard? Also what about Visual Studio 2017 support getting added to Lumberyard? Hopefully this can get done fairly soon. Thank-you!

Can these items please be put towards the top of the list? (or possibly hire a few extra developers that can focus solely on supporting the latest applications/tools such as 3ds Max 2018, Maya 2018, and Visual Studio 2017 build support in Lumberyard). Application Support and Tool/Plugin support always seems to really be lacking and lagging behind in Lumberyard. Can this please be “bumped up” to be a major priority in Lumberyard? Or can you please possibly add a few extra devs that can focus solely on Application/Tool/Plugin support for Lumberyard? (for Maya 2018, Maya 2019, and 3ds Max 2018, 3ds Max 2019, and Visual Studio 2017, and Visual Studio 2019).

(I’m just mentioning the 2019 releases, because by the time the 2018 releases are finally added and supported, the 2019 releases will probably already be out…) Hopefully this can get fixed/addressed fairly quickly, and hopefully Lumberyard can be updated fairly quickly to support the latest versions of current dev tools (Maya 2018, 3ds Max 2018, and Visual Studio 2017), as well as working on supporting future dev tools (Maya 2019, 3ds Max 2019, and Visual Studio 2019).

Maya 2018, 3ds Max 2018, and Visual Studio 2017 have been out for quite some time, and hopefully these can be added to Lumberyard fairly quickly. Thank-you!

Hey @Mark.Malewski — totally valid feedback and request. I’ve added this to our list for further action and improvement :smiley: Thanks for helping improve Lumberyard!

@Ajia @Amonster_LMBR @Binky_LMBR

Any news on when Visual Studio 2017, Maya 2018, 3ds Max 2018, Mudbox 2018, and Blender 2.8 will be added to the very latest Lumberyard Setup Assistant?

@Amonster_LMBR @Ajia @Binky_LMBR

Any news on when Visual Studio 2017, Maya 2018, 3ds Max 2018, Mudbox 2018, and Blender 2.8 will be added to the very latest Lumberyard Setup Assistant?

Maybe even a plugin for Maya 2019, and 3ds Max 2019? We still don’t have plugins for the 2018 3ds Max and 2018 Maya, or the latest blender.

Is there a 3ds Max 2017? I don’t see this in my setup assistant with 1.12.0.1