White layer and wrong animation problem

Some problems with animation and material. I have made model in Blender But when I import this model in Lumberyard and assign material, it seems the editor adds an additional white texture or something. I tried different options in material editor, but no result. Here the video how it looks and works in Blender, and then in Lamberyard. Any ways to remove this white layer? https://youtu.be/6qwxXj8Aqqo

There are also an animation problem, I tried different expot FBX settings and Lumbermixalot plugin also, but animation still works wrong. The most strange thing is that knight also was edited in Blender(its from Mixamo) and his animations works perfectly well (I have exported his animations with the same settings).

After some experiments with diffuse and specular colors the texture looks fine in game, but still a big problem with animation.

Hi Phantomny,

Which version of Lumberyard are you using?

Thanks.

Hello, its 1.24.1.0.

Gotcha, I’ve found a previous post on a similar issue with importing FBX from Blender, Import FBX to LY from Blender 2.8

It offers some possible solutions, and let me know if it works.

Problem was in the metric system, I set units scale to 0.01 (found decision in other topic). Now animation works fine)

Awesome, glad you found a solution for this.