Why my fleet went on ERROR state?

From my GameLift web console:

everything was fine till 2021-03-04 20:32:50 UTC+0100 (I download all downloadable logs and they was fine), but the fleet stayed for about an hour in ACTIVATING state then went in ERROR state without the evidence of an error.
I connected in ssh to the created instance and from the logs I learned that GameLift neither tied to launch a server.

Please ignore the last error message: from the ssh connection I tried to launch the server by hands and it worked as expected (obviously untill it tried to connect to GameLift).

What should have been happened in that hour to avoid the fleet to go in ERROR state?

Thank you

P.S.
Fleet ID (to easly cut&paste it in case you need): fleet-f486d04a-e5c6-475c-8f44-d23c14747ed2

From your fleet events:

  • GameLift launches sets-up your server image
  • Then launches server process
  • Some process attempts and fails to call InitSDK correctly
  • GameLift retries by relaunching your server

  • Fleet errors out

This is to be expected. GameLift is trying to launch your server and retries for some time during fleet creation. This is to cover for transient issues such as temporary networking failures.

What it looks like is that the process you asked GameLift to launch via the runtime configuration part of CreateFleet is not the process calling back for InitSDK.

Theres no current method to customize Fleet error timeouts AFAIK. The good news is that you do not pay for instances that aren’t in ACTIVE state but it is frustrating when you are trying to diagnose and solve fleet creation errors.

Hope that helps