Windows Remote Access won't connect to GameLift Fleet, what am I doing wrong?

Hi all,

So I’m trying to remotely access my GameLift fleet because something is going wrong with my server instance which causes GameLift to terminate my server because the it isn’t reporting back as healthy.

But I’ve been unable to remotely access my fleet. My fleet is “Active” so no problems there. I made sure to turn on Windows Remote Access on my computer, so I think I’m okay on that front. I’ve also tried to follow the documentation for windows here:

This is what my environment looks like:



And the error I get:


So I use CLI to get the fleet IP address and instance ID. I also get the password and user name to actually connect to the server (although I never get to that step). Then I make sure the ports I’m trying to connect to are open, as you can see I’ve tried a lot of them. And then finally I try to connect to the server via Windows Remote Desktop Connection. I’m not exactly sure if that’s the correct port, or if I’m formatting the IP address correctly.

What am I doing wrong?

I would appreciate any help, thanks.

Fleet ID: fleet-e17768ce-c8ed-40f8-86dc-eeac7a9db63b

Region: us-west-2

Firstly, apologies as the documentation here for windows is not that clear and missing examples.

Heres the abbreviated WINDOWS via RDP instructions:

  1. Open RDP port on the fleet.
  2. Go to the GameLift console and find your fleet.
  3. Hit “edit fleet.” Scroll down to the “Ports” section and click “Add.”
  4. Open TCP port 3389 (3389 is the RDP port - has to be open on your fleet), ideally scope this to your ip
  5. Save/update the settings
  6. Find out an instance ID from your fleet (if its for a particular game session, look at the game session tab to get the ip for the game session):
  7. Get the running instances of your fleet.
aws --region <region of your fleet> gamelift describe-instances --fleet-id <your fleet ID>
  1. You will get back a list of instances. Find the IP for the game session you care about if appropriate or just pick any instance in your fleet, and note the “instance ID” field of that item.
  2. Get credentials for your instance.
aws --region <region of your fleet> gamelift get-instance-access --fleet-id <your fleet ID> --instance-id <instance ID from step 3b>
  1. Connect to your instance.
  2. Open up remote desktop and connect to the IP from step 2b.
  3. Enter credentials.
  • For the user, enter “<ip of the instance>\gl-user-remote
  • For the password, enter the password you got in step 3c.
    That should do it, let me know if you have any problems.

Yeah, that worked thanks @Pip . The problem was that the port 3389 was blocked on my network. But I was able to get someone on a different network to use RDP to connect and it worked for them. So thanks!

I get this error: “An error occurred (UnrecognizedClientException) when calling the GetInstanceAccess operation: The security token included in the request is invalid.”

Hey Davinder,

Looks like the credentials used to call the GetInstanceAccess API might be invalid/expired. Which language of the AWS SDK are you using?

Here are some references which might be helpful to help configure your credentials correctly: