Wwise Gem Problem after Building the Gem

Hi, No matter how many times I build the gems with

 lmbr_waf build_win_x64_vs2017_profile -p all 

I get this error in the Editor with when it starts

then after opening a level this happens

Capture

plus why on earth I get all those warning when running lmbr_waf configure

C:\Amazon\Lumberyard\1.22.0.0\dev>lmbr_waf configure
[WAF] Engine Root: C:\Amazon\Lumberyard\1.22.0.0\dev\
[WAF] Executing 'configure'
[WARN] Missing JDK path from Setup Assistant detected. Target platforms that require java will be disabled. Please re-run Setup Assistant with "Compile For Android" enabled and run the configure command again.
[WARN] Unable to process 3rd party config file 'angle.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\ANGLE\win32': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\angle.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'ANGLE' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'benchmark.json': Invalid/missing INCLUDES value 'C:\Amazon\Lumberyard\1.22.0.0\3rdParty\benchmark\1.4.1\include': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\benchmark.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'BENCHMARK' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'crashpad.json': Invalid/missing INCLUDES value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Crashpad\include': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\crashpad.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'CRASHPAD,CRASHPAD_HANDLER' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'd3d_compiler.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\D3DCompiler\win32': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\d3d_compiler.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'D3D_COMPILER,D3D_COMPILER_43,D3D_COMPILER_46,D3D_COMPILER_47' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'dbg_help.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\DbgHelp\win32': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\dbg_help.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'DBG_HELP' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'libav.json': Invalid/missing INCLUDES value 'C:\Amazon\Lumberyard\1.22.0.0\3rdParty\libav\11.7\usr\include': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\libav.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'LIBAV' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'msvc90.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\MSVC90': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\msvc90.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'MSVC90' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'opengl32.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\OpenGL32': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\opengl32.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'OPENGL32' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'ssleay.json': Invalid/missing LIBPATH value 'c:\Amazon\Lumberyard\1.22.0.0\dev\Tools\Redistributables\SSLEAY\win32': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\ssleay.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'SSLEAY' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'wwise.json': Invalid/missing INCLUDES value 'C:\Amazon\Lumberyard\1.22.0.0\3rdParty\Wwise\2018.1.4.6807\SDK\include': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\wwise.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'WWISE' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WARN] Unable to process 3rd party config file 'wwise2017.json': Invalid/missing INCLUDES value 'C:\Amazon\Lumberyard\1.22.0.0\3rdParty\Wwise\2018.1.4.6807\SDK\include': (c:\Amazon\Lumberyard\1.22.0.0\dev\_WAF_\3rdParty\wwise2017.json, platform win_x64_vs2017)
[WARN] Unable to configure uselibs 'WWISE2017' for platform 'win_x64_vs2017'. This may cause build errors for modules that depend on those uselibs for that platform
[WAF] 'Initialize Build Variants' starting...
[INFO] Target platform android_armv8_clang disabled due to not java not properly initialized through Setup Assistant.
[WAF] Configure "win_x64_vs2017 - [profile,performance_dedicated,profile_test_dedicated,debug_dedicated,debug_test_dedicated,release,release_dedicated,debug_test,debug,performance,profile_dedicated,profile_test]"
[INFO] Using Visual Studio version 15 installed at: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community
[WAF] 'Initialize Build Variants' successful (1.374s)
[WAF] 'Configure Projects' starting...
[WAF] 'Configure Projects' successful (3.458s)
[WAF] 'configure' finished successfully (5.644s)
[WAF] Executing 'msvs' in 'c:\Amazon\Lumberyard\1.22.0.0\dev\BinTemp'
[INFO] Using Visual Studio version installed at: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community
[INFO] Generating Visual Studio 2017 solution.
[WARN] Invalid module 'AmazonQtControlGallery' in spec 'all'
[WARN] Invalid module 'LyIdentity_shared' in spec 'all'
[WARN] Invalid module 'LyIdentity_static' in spec 'all'
[WARN] Invalid module 'LyInstallerMetrics' in spec 'all'
[WARN] Invalid module 'LyMetricsConsumer' in spec 'all'
[WARN] Invalid module 'LyMetricsProducer_python' in spec 'all'
[WARN] Invalid module 'LyMetricsProducer_shared' in spec 'all'
[WARN] Invalid module 'LyMetricsProducer_static' in spec 'all'
[WARN] Invalid module 'LyMetricsShared_shared' in spec 'all'
[WARN] Invalid module 'LyMetricsShared_static' in spec 'all'
[WARN] Invalid module 'LyzardGems' in spec 'all'
[WARN] Invalid module 'LyzardEngines' in spec 'all'
[WARN] Invalid module 'LyzardProjects' in spec 'all'
[WARN] Invalid module 'NewsBuilder' in spec 'all'
[WARN] Invalid module 'ToolsCrashUploader' in spec 'all'
[WARN] Invalid module 'SerializeContextTools' in spec 'all'
[WARN] Invalid module 'DeltaCataloger' in spec 'all'
[WARN] Invalid module 'LyIdentity_shared' in spec 'game_and_engine'
[WARN] Invalid module 'LyIdentity_static' in spec 'game_and_engine'
[WARN] Module use dependency 'CrashHandler' for target 'CrySystem' refers to an invalid module
[WARN] Module use dependency 'ToolsCrashHandler' for target 'EditorLib' refers to an invalid module
[WARN] Module use dependency 'ToolsCrashHandler' for target 'AssetProcessor' refers to an invalid module
[WARN] Module use dependency 'ToolsCrashHandler' for target 'LuaIDE' refers to an invalid module
Creating c:\Amazon\Lumberyard\1.22.0.0\dev\Solutions\LumberyardSDK_vs15.sln
[WAF] 'msvs' finished successfully (25.050s)
[WAF] Executing 'generate_uber_files' in 'c:\Amazon\Lumberyard\1.22.0.0\dev\BinTemp'
[WAF] 'generate_uber_files' finished successfully (14.957s)
C:\Amazon\Lumberyard\1.22.0.0\dev>

Alot of problems with building Gems please assist in this issue… thanks

Hey @NorthEGames I never used the wwise gem yet, so that may have problems on its own but if you go on the lumberyard website and downloads page you can request an earlier download, and get version 1.21 which I had no problem building projects in and I never got the saving a backup file in. That seems to be something with the new version.

Hi @WashedUpStudios I am trying hard to fix the errors, but I don’t know if earlier version will be a better choice, Anyhow could you share the link to get the older version of Lumberyard?

I have been getting the exact same error myself with 1.22

I think I found the solution but not sure yet, I think there are optional SDKs not downloaded and setup in the 3rd party folder yet I need to download them and check back.

try downloading all the optional SDKs you need

I hope the optional SDKs work, because to get an older version you have to hope they will send it to you by filling out this form.

Ok if you want a previous version you can only get 1.20 and before. 1.21 is not on their list, and I don’t see why not but here is the list.

> list